#1  
Old 30th May 2012, 15:05
bitla bitla is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default centos fcgid installation

Hello,

I am newbie to Linux, I thank you for providing well crafted Howto's. I am try to setup a local webserver on my pc. I have installed CentOS 5.X, update it, installed Apache2, php5, mysql with help of your website.

At present the server API is Apache2 Handler, I am trying to change to CGI/FASTCGI.

The below webpage gives instructions to install it but the repository link given in the step 2 provided is not found. ( wget http://dl.fedoraproject.org/pub/epel...6-5.noarch.rpm)

webpage:


http://www.howtoforge.com/how-to-set...-centos-6.2-p2

Please update the repository link.

One question I would like to ask, may be at the wrong place.

I have a php script which after installation and when website is opened it produces .html pages . This is working fine on my paid hosting service but not on localhost. It give me error message "page not found"

example: www.mydomain.com will output www.mydomain.com/index.html with page not found error message.

It is a music script (may be designed on joomla).

What modules and extension would be required for the script to work properly.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 31st May 2012, 23:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by bitla View Post
Hello,

I am newbie to Linux, I thank you for providing well crafted Howto's. I am try to setup a local webserver on my pc. I have installed CentOS 5.X, update it, installed Apache2, php5, mysql with help of your website.

At present the server API is Apache2 Handler, I am trying to change to CGI/FASTCGI.

The below webpage gives instructions to install it but the repository link given in the step 2 provided is not found. ( wget http://dl.fedoraproject.org/pub/epel...6-5.noarch.rpm)

webpage:


http://www.howtoforge.com/how-to-set...-centos-6.2-p2

Please update the repository link.
The correct link is now http://dl.fedoraproject.org/pub/epel...6-7.noarch.rpm

I've updated it in the tutorial.

Quote:
Originally Posted by bitla View Post
I have a php script which after installation and when website is opened it produces .html pages . This is working fine on my paid hosting service but not on localhost. It give me error message "page not found"
Does the script generate HTML pages (like index.html), or does it just redirect to existing HTML pages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st June 2012, 08:14
bitla bitla is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Falko,

script generates html pages. script name is agriya volume version 2.0.9

When I use the command rpm -ivh epel-release-6.7.noarch.rpm I get the below error message
error: Failed dependencies
rpmlib (FileDigests) <= 4.0.6.0-1 is need by epel-release-6.7.noarch
rpmlib (FileDigests) <= 5.2-1 is need by epel-release-6.7.noarch

Last edited by bitla; 1st June 2012 at 08:26.
Reply With Quote
  #4  
Old 2nd June 2012, 11:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by bitla View Post
When I use the command rpm -ivh epel-release-6.7.noarch.rpm I get the below error message
error: Failed dependencies
rpmlib (FileDigests) <= 4.0.6.0-1 is need by epel-release-6.7.noarch
rpmlib (FileDigests) <= 5.2-1 is need by epel-release-6.7.noarch
Please install rpmlib...
Code:
yum install rpmlib
... and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
apache2, centos, fastcgi, php5

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems connecting my HTC Desire outgoing mail client to Postfix and ISP Config 2 j.smith1981 Server Operation 6 12th July 2010 19:07
Centos 5.2 - ISPconfig 3 installation and it's bugs/problems bl4ckb1rd Installation/Configuration 15 31st August 2009 16:40
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
CentOS 5.1 - ISPConfig Installation completed but init.d/ispconfig_server not found?? tozden Installation/Configuration 1 15th May 2008 10:21
Warning CentOS 4.3 Installation d3m0nic HOWTO-Related Questions 3 19th April 2006 15:40


All times are GMT +2. The time now is 01:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.