Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 22nd May 2012, 13:06
vaya vaya is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks!

after 3 days, I got it working too!

to resume, all you have to do
WHEN :
you get a HTTP Error 502 Bad gateway
with nginx and Owncloud (and in my case ISPConfig)

IS :

Quote:
vi /etc/php5/fpm/pool.d/www.conf
change to 127.0.0.1:9000

vi /etc/nginx/sites-available/YOURSITE.com.vhost
change to 127.0.0.1:9000

/etc/init.d/nginx restart
/etc/init.d/php5-fpm restart
Reply With Quote
Sponsored Links
  #12  
Old 23rd May 2012, 14:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Your changes will be overwritten the next time you modify the vhost in ISPConfig. If it's not working with the configuration written by ISPConfig, there's probably something wrong with your setup, and you should check your logs.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 25th May 2012, 02:31
vaya vaya is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

you're right, the victory was short lived ..

I decided to Use Socket For PHP-FPM

by checking this box in ISPConfig:

Quote:
Sites > mysite.com > Options > Use Socket For PHP-FPM
so now my vhost file looks like this :

Quote:
location ~ \.php$ {
try_files $uri =404;
include /etc/nginx/fastcgi_params;
fastcgi_pass unix:/var/lib/php5-fpm/web9.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_intercept_errors on;
}
works fine so far


Ubuntu 12.04
ISPConfig 3
Owncloud 3.0.3

Last edited by vaya; 25th May 2012 at 02:33.
Reply With Quote
  #14  
Old 4th February 2014, 19:29
Gwyneth Llewelyn Gwyneth Llewelyn is offline
Junior Member
 
Join Date: Feb 2014
Location: Neufreistadt, Confederation of Democratic Simulators, Second Life
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to Gwyneth Llewelyn Send a message via AIM to Gwyneth Llewelyn Send a message via MSN to Gwyneth Llewelyn Send a message via Yahoo to Gwyneth Llewelyn Send a message via Skype™ to Gwyneth Llewelyn
 
Default

So if I understand you correctly, you created a separate vhost just for running ownCloud alongside with ISPConfig 3?

Also, I guess that you're using completely different nginx configuration rules than the ones found on the ownCloud wiki.

This sounds interesting, though
__________________
I'm just a virtual girl in a virtual world...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu server + java JDK + nginx (as proxy to jetty) + jetty + mysql + memcached bokivaol Suggest HOWTO 0 12th February 2012 16:57
Tutorial: The Perfect Server – Ubuntu 11.10 [ISPConfig 3] pureftpd issue madlars HOWTO-Related Questions 12 19th January 2012 12:20
Install Zoneminder 1.25 source wi Ubuntu Server 11.10 64bit, libjpeg-turbo, Cambozola letsharehowto HOWTO-Related Questions 0 15th November 2011 16:23
Installing Nginx With PHP5 (And PHP-FPM) And MySQL Support On Ubuntu 10.10 SamTzu HOWTO-Related Questions 5 27th November 2010 21:53
ISPConfig 3 + Ubuntu 9.04 Configuration danielborene General 6 13th June 2009 22:16


All times are GMT +2. The time now is 13:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.