#1  
Old 20th April 2012, 00:19
matrixn matrixn is offline
Member
 
Join Date: Jul 2008
Location: Ramnicu Valcea, Valcea, Romania
Posts: 47
Thanks: 6
Thanked 2 Times in 2 Posts
Send a message via Yahoo to matrixn
Exclamation users problems

i have a problem with my ispconfig 2.2.39 instalation on a opensuse 11.4 machine.

The problem started few days ago when i was creating and changing passwords for users emails. the problem was that i couldn`t login into my machine with root user... after some digging and googleing... i find out that my /etc/passwd, /etc/group and /etc/shadow where empy... so i create the users and groups from backups but the ispc users and groups where not in backup so i had to create them manualy and map them to correct uids/gids.

so far evrything works... exept that if i change at least one password from ispc admin, all my group, shadow and passwd files are incompletly filled and sometimes the system users like root are missing... is there a way to fix this?
__________________
Best regards,
Raduta Alex-Radu

Last edited by matrixn; 20th April 2012 at 00:24.
Reply With Quote
Sponsored Links
  #2  
Old 20th April 2012, 15:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Please upgrade to 2.2.40 and try again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th May 2012, 17:05
Numerizen Numerizen is offline
Member
 
Join Date: Dec 2007
Location: Cherbourg -FRANCE
Posts: 97
Thanks: 26
Thanked 7 Times in 6 Posts
 
Default

Didn't notice this message before posting this one : http://www.howtoforge.com/forums/showthread.php?t=57268, which basically describes the same problem.

May I ask if the upgrade is safe even after the problem appeared ?

Second question : what is the safer, and if possible automatic way to restore all the data in these files ? I read about some writeconf script but the thread was rather old so didn't dare to try.

Last question : should these files be backed up, as they're quite important but the information in it should remain confidential, so maybe it's not a good idea to replicate it ?

Last question number two : is there a known origin to this problem, or is it complete random ? I asked the question about an unusual (for me) domain name, but it's only an uneducated guess.

Please help this poor soul who fears to touch anything since its world crumbled down two days ago.

Last edited by Numerizen; 12th May 2012 at 19:54.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with ISPConfig Mail and Squirrelmail m.xander Installation/Configuration 109 3rd February 2012 00:15
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
Problem with Clamav + samba configuration wammy28 HOWTO-Related Questions 8 31st January 2009 19:12
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11


All times are GMT +2. The time now is 16:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.