Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th May 2012, 20:51
bizkid64 bizkid64 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with Namevirtualhosts and SSL

I've set up ISPConfig 3 based servers several times, but I haven't had this problem before. Makes me think I'm missing something obvious.

I just a clean install of Debian Squeeze & ISPConfig3 using the Perfect Server and Extending the Perfect Server how-to's.

During set up, I set eth0 to 192.168.0.100, and eth0:0 to my external IP of 67.41.xxx.xxx), and I chose the access ISPConfig control panel through SSL option.

I would like to set up one SSL site on this server for right now, so I have set the Server IP (System > Server IP Addresses > IP Addresses) to my external IP (67.41.xxx.xxx) and left the HTTP NameVirtualHost box unchecked.

I then create a website (Sites > Website > Web Domain) and select the 67.41.xxx.xxx ip address from the IPv4 drop down box, enter my domain name (casemanagerbk.com), select www. as the auto-subdomain and check the SSL box and leave everything else on the default settings.

At this point, the ls -la output of /var/www/clients/client1 is
Code:
drwxr-xr-x 3 root root    4096 May 10 11:44 .
drwxr-xr-x 3 root root    4096 May  8 15:24 ..
lrwxrwxrwx 1 root root      30 May 10 11:44 casemanagerbk.com -> /var/www/clients/client1/web1/
drwxr-x--x 6 web1 client1 4096 May 10 11:44 web1
and the ls -la output of /etc/apache2/sites-available is
Code:
drwxr-xr-x 2 root root 4096 May 10 11:46 .
drwxr-xr-x 7 root root 4096 May  9 10:57 ..
-rw-r--r-- 1 root root 1022 May  8 15:13 apps.vhost
-rw-r--r-- 1 root root 2849 May 10 11:46 casemanagerbk.com.vhost
-rw-r--r-- 1 root root  692 Apr  1 00:39 default
-rw-r--r-- 1 root root 7251 Apr  1 00:39 default-ssl
-rw-r--r-- 1 root root 1339 May 10 11:41 ispconfig.conf
-rw-r--r-- 1 root root 1776 May  9 08:31 ispconfig.vhost
However, when accessing the site, I am only seeing the apache server default page "It works!," not the ISPConfig default index.html file in the web1/web folder. If I change the website IPv4 setting to "*", then I can see the proper index.html file.

I then create the SSL certificate, and save my StartSSL certificate in the field.

I am still able to access the site over http:, but not through https:. I think the problem here is that I still have the "*" selected in the site's IPv4 setting, but changing it the IP address results in getting the server default page again.

Any help getting the right settings here would be appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2012, 22:15
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 90 Times in 68 Posts
Default

you will check HTTP namevirtualhost if you want to use this ip in virtual hosts. after that use the ip instead * for your ssl site. Also you can use SNI for several certificates in that ip

cheers
Reply With Quote
  #3  
Old 11th May 2012, 00:17
bizkid64 bizkid64 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Pititis -

I sincerely thank you for the reply, but what you tell me to do is exactly what isn't working. It should, and it has every time I've installed this before, but not now.

The fact that what you suggest isn't working is exactly the source of my frustration.

So thank you, but I can't call the problem solved yet.
Reply With Quote
  #4  
Old 11th May 2012, 10:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
I would like to set up one SSL site on this server for right now, so I have set the Server IP (System > Server IP Addresses > IP Addresses) to my external IP (67.41.xxx.xxx) and left the HTTP NameVirtualHost box unchecked.
I guess you used the wrong IP. You must use an IP that you can see in the output of
Code:
ifconfig
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 12th May 2012, 00:48
bizkid64 bizkid64 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I double-checked the IP in my static block, what I set up in /etc/network/interfaces, and what outputs from ifconfig. Here's the output from ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20d:56ff:febb:8ff8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10921 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8313 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4241766 (4.0 MiB)  TX bytes:2224915 (2.1 MiB)
          Interrupt:28

eth0:0    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:1    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.103  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:2    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.105  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:3    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.107  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:4    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.109  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:5    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.111  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:6    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.113  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:7    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.115  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:8    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.117  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:9    Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:192.168.0.119  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:10   Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:67.41.184.217  Bcast:67.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:11   Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:67.41.184.218  Bcast:67.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:12   Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:67.41.184.219  Bcast:67.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:13   Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:67.41.184.220  Bcast:67.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

eth0:14   Link encap:Ethernet  HWaddr 00:0d:56:bb:8f:f8
          inet addr:67.41.184.221  Bcast:67.255.255.255  Mask:255.0.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:28

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10010 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10010 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:833585 (814.0 KiB)  TX bytes:833585 (814.0 KiB)
The problem seems to be coming from the fact that I cannot get anything to be served through the public IP address 67.41.184.xxx unless I check the NameVirtualHost box when setting up the server IP, and I also set the website IP address in the Site configuration dialog to "*." If I do that, I can get the right content to serve through http, but nothing through https.
Reply With Quote
  #6  
Old 12th May 2012, 11:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by bizkid64 View Post
unless I check the NameVirtualHost box when setting up the server IP
Yes, you must check NameVirtualHost. Also make sure you include port 443 (https) in the ports list.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.