#1  
Old 9th May 2012, 09:49
bo17age bo17age is offline
Junior Member
 
Join Date: Mar 2010
Posts: 2
Thanks: 2
Thanked 0 Times in 0 Posts
Default Email forward doen't work

Hello, i have this problem after upgrade to ispconfig 3.0.4.4
Quote:
s3:~# mailq
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
63551BEF45 12312 Wed May 9 09:27:57 liennguyen126@yahoo.com
(temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/hongha.asia/nhapmua/10547.0.s3.hongha.asia.)
nhapmua@hongha.asia

6D82BBEECA 20103 Wed May 9 10:07:58 linhlx@hongha.asia
(temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/hongha.asia/kehoach/10534.0.s3.hongha.asia.)
kehoach@hongha.asia
(temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/hongha.asia/kinhdoanh/10627.0.s3.hongha.asia.)
kinhdoanh@hongha.asia

016B5BEF0C 60207 Wed May 9 08:34:35 hongdt@hongha.asia
(temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/hongha.asia/kiemsoat/10467.0.s3.hongha.asia.)
kiemsoat@hongha.asia
(temporary failure. Command output: /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/hongha.asia/nhapmua/10517.0.s3.hongha.asia.)
nhapmua@hongha.asia

nhapmua@hongha.asia & kinhdoanh@hongha.asia are email forward.

this is my main.cf
Quote:
s3:/etc/postfix# cat main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtp_use_tls = yes
smtpd_tls_auth_only = no
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = s3.hongha.asia
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = s3.hongha.asia, localhost, localhost.localdomain
relayhost = 112.78.3.187
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
#smtpd_sender_restrictions = reject_unknown_sender_domain,check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_sender_login_maps = mysql:/etc/postfix/mysql_login_maps.cf

smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
#content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0

smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
always_bcc = backup@hongha.asia
smtpd_client_message_rate_limit = 100
owner_request_special = no
#smtp_sender_dependent_authentication = yes
#smtp_sasl_security_options = noanonymous
#sender_dependent_relayhost_maps = mysql:/etc/postfix/mysql-sender_relay_hosts.cf
#smtp_sasl_password_maps = mysql:/etc/postfix/mysql-sender_relay_hosts_auth.cf
#smtp_connection_cache_on_demand = no
s3:/etc/postfix#
please help me at this!
Thank you!
Reply With Quote
Sponsored Links
  #2  
Old 9th May 2012, 10:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

The reason for your problem is that you disabled the content filter:

#content_filter = amavis:[127.0.0.1]:10024

To fix it, either enable the content filter again or disable the :

receive_override_options = no_address_mappings

option as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
bo17age (9th May 2012)
  #3  
Old 9th May 2012, 11:35
bo17age bo17age is offline
Junior Member
 
Join Date: Mar 2010
Posts: 2
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

thank you till
it works now =))
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Spam Filter on Email forward primal23 Installation/Configuration 1 7th April 2010 09:56
email account and email forward acumen General 4 28th October 2009 11:00
Email forward ... BorderAmigos General 3 5th June 2009 11:20
email forward problem createch General 5 10th December 2008 14:14
BUG: Forward email? edge General 3 1st June 2007 16:49


All times are GMT +2. The time now is 21:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.