Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd May 2012, 17:36
jpwalters jpwalters is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default vlogger: piped log program failed unexpectedly

Ubuntu 12.04 LTS
ISPConfig Version: 3.0.3.3

I'm getting the following errors numerous times in my apache2 error.log file.

Code:
piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
How can I resolved this issue?

Note: I read this other post and installed perl-DBD-mysql perl-DBI and then restarted apache but I'm install getting the same error.
Reply With Quote
Sponsored Links
  #2  
Old 3rd May 2012, 17:44
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,041
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

Try:

apt-get install vlogger

to see if any required packages are missing.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd May 2012, 18:59
jpwalters jpwalters is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
root@domU-12-31-39-03-C0-08:/tmp/sasl# apt-get install vlogger                                                                                                  Reading package lists... Done                                                                                                                                   Building dependency tree                                                                                                                                        Reading state information... Done                                                                                                                               
vlogger is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libsasl2-modules-sql : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not installable
Great so that's the problem...vlogger is missing a dependency. Which I likely created the problem myself.

History: Over the weekend I upgraded Ubuntu from 11.xx to 12.04. After I did that I ran into this issue "saslauthd: SASL PLAIN authentication failed: no mechanism available" ... which basically just meant I couldn't send emails. I followed this post http://www.howtoforge.com/ubuntu-11....nism-available and that fixed my problem. Ultimately the fix was just to downgrade a few packages from version libsasl2-2_2.1.25 to libsasl2-2_2.1.23 which possibly is what has broken vlogger.

If I run apt-get -f install as suggested it will re-upgrade to version x.25 which cause the emailing sending problem but still I end up with libmysqlclient16 (>= 5.1.21-1) not getting installed.

How can I install libmysqlclient16 without also upgrade to version x.25 to keep from breaking my other issue?

Note: If I had a path to switch to using Dovecot (instead of Courier) for smtp authentication then the email sending issue would likely get resolved and possible my currently issue would also get resolved.

Thanks for the quick help.
Reply With Quote
  #4  
Old 4th May 2012, 09:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Take a look at apt-pinning: http://www.howtoforge.com/a-short-in...to-apt-pinning
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
vlogger

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 won't start after update Cracklefish Installation/Configuration 15 28th February 2012 14:11
Need help with ISPConfig Mail and Squirrelmail m.xander Installation/Configuration 109 3rd February 2012 00:15
Monit on Debian Hans Tips/Tricks/Mods 2 6th October 2008 13:53
Monit & Munin SamTzu HOWTO-Related Questions 1 4th May 2008 18:03
ispconfig_access_log failed unexpectedly dsadm Installation/Configuration 6 27th June 2007 10:49


All times are GMT +2. The time now is 10:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.