Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd May 2012, 17:14
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think I found my bug
After vi /etc/php5/cgi/php.ini
uncomment
cgi.fix_pathinfo=1

It seems to work.

Thanks for the support

Cyprus
Reply With Quote
Sponsored Links
  #12  
Old 7th May 2012, 16:13
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Nginx Trouble seems to be endless.

In my last post I mentioned a solution which doesn´t work with any theme.
I uploaded an HTML5 theme and I can´t get into my backend anymore.
In this case I get an Error 500.

And again heading for a solution. But at the moment I´aint got no clue where the Error is coming from.

Has anybody any suggestions.

Thanx in advance.
Reply With Quote
  #13  
Old 27th August 2012, 12:23
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 37
Thanks: 8
Thanked 6 Times in 5 Posts
Default

I also experienced a server 500 error. Installing WordPress. No lines in the error.log.

It turns out that the 5-minute installer throws this (write permission?). Supplying a valid, manually filled out wp-config.php resolved this issue. I was expecting the "generate one for you" prompt but to no avail.

So far, so good.
Reply With Quote
  #14  
Old 27th August 2012, 12:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,782
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

Your error can have 2 possible reasons:

1) You did not choose php mode: php-fastcgi + suexec: on as described in the manual for cms sites.
2) The wordpress files were not owned by the user and group of the website e.g. when you did not upload them by php or missed to chown them after you unpached them as root user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Steveorevo (27th August 2012)
  #15  
Old 27th August 2012, 13:23
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I made the same experience, but I don´t need the automatic installer. So each Installation I do is manually by preparing the wp-config.php before.
Reply With Quote
  #16  
Old 27th August 2012, 13:30
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 37
Thanks: 8
Thanked 6 Times in 5 Posts
Default

I rolled back my Virtual Machine and checked permissions and tried again. Odd, it still throws a 500 for what should be a "Database connection error".

In fact, on a plain WP install, simply changing the DB_NAME to something incorrect causes a 500 Server Error and not the expected DB error message. I am using a wildcard subdomain for "dev.mywebsite.com". Could that be it? I thought I have seen legitimate "DB connection error" messages on Nginx prior; perhaps they were "www" sites.
Reply With Quote
  #17  
Old 27th August 2012, 13:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,782
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

Take a look at the error.log of the website, you will find the php error message there.

The reason that you see a 500 error instead of the error message on the page is a configuration option in the php.ini file. All current php versions of the Linux distributions have display_errors set to Off. If you set it to On and restart apache afterwards, you will see php errors in the page.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 27th August 2012, 14:06
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 37
Thanks: 8
Thanked 6 Times in 5 Posts
Default

Hi Till,
Thank you for your reply. Sorry, I think I posted in the wrong thread. This was in response to Cyprus' "Nginx Trouble seems to be endless."

Nginx seems to be fine (and fast!). But I am experiencing this on Nginx, not Apache. I tried setting display_errors = true and then display_errors = On in the ISPConfig php.ini options, but I'm still seeing a 500 Server Error if I purposely put in a wrong database name. This of coarse, is not something I would normally run a site with anyways. Thank you for your feedback :-)
Reply With Quote
  #19  
Old 27th August 2012, 14:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,782
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

It does not matter if you use apache or nginx for this problem as it is a php setting. If you use nginx, then the php-fpm servers ahve to be restarted after the php.ini change to tell php to show errors on the screen instead of logging i to the file. If you do any changes in ispconfig instead of editing the php.ini like i suggested, then ensure that you waited until they got written to disk, you can see this in the monitor.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #20  
Old 27th August 2012, 14:21
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 37
Thanks: 8
Thanked 6 Times in 5 Posts
 
Default

Hi Till,
I waited for the update to flush the queue. Its late here in California. But I'll roll back my VM later and see if I can duplicate the issue (hopefully not possible), but will apply your steps as suggested. Thank you for your followup!

Regards,
Steve
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13 MrCompTech Tips/Tricks/Mods 8 25th August 2014 15:18
wordpress multisite a0011010011 Installation/Configuration 8 14th February 2012 23:44
ISPConfig 3.x - First Steps (Creating Web Sites, Email Addresses, Etc.) sighkick Suggest HOWTO 18 7th October 2010 01:12
ispconfig wordpress and directory/file permissions willebanks Installation/Configuration 4 9th March 2010 22:52
wordpress u Amorphous Installation/Configuration 2 10th July 2009 11:00


All times are GMT +2. The time now is 17:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.