Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th April 2012, 23:21
morten44 morten44 is offline
Member
 
Join Date: Apr 2012
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
Default Cant install Plugins for squirrelmail

Hi
Have setup ispconfig using this manual:
http://www.howtoforge.com/perfect-se...10-ispconfig-3

I have an issue installing a plugin for squirrelmail called "change_sqlpass" so each user can change the password for their own account

I have installed it using the following instructions:
http://www.howtoforge.com/how-to-con...onfig-3-server

When I go in and try to change password i get error:
Quote:
ERROR:Could not find Pear DB library
Warning: include_once(DB.php): failed to open stream: No such file or directory in /usr/share/squirrelmail/plugins/change_sqlpass/functions.php(50) : eval()'d code on line 1 Warning: include_once(): Failed opening 'DB.php' for inclusion (include_path='.') in /usr/share/squirrelmail/plugins/change_sqlpass/functions.php(50) : eval()'d code on line 1

So I read out from this that my include_path="."
It should be /usr/share/php: /usr/share/php/PEAR

So I upload a phpinfo.php file and contact the squirrelmail comunity as it looks ok: http://www.sommerlejr-hellebaek.dk/phpinfo.php

They asked me to run the phpinfo.php from squirrel library and so I did
(using https as cant get domain/webmail to work)
https://sommerlejr-hellebaek.dk:8080...il/phpinfo.php
and to my suprise it now shows include_path="."

I have updated php.ini in /etc/php5/apache2/php.ini and the php.ini in the cgi folder

I then tried to add a line to .httaccess file:
php_value include_path ".:/usr/share/php: /usr/share/php/PEAR"
no joy

Then they say that my system is setup to not read the .htaccess file and they mention several steps I should take. As a newbee i dont understand mutch of it and I am affraid it will affect how ipsconfig works so thats why I contact you guys to see if you have any idea

You can see the thread here:
http://old.nabble.com/change_sqlpass...html#a33755025

Do you have any idea why its not working?
Why cant I get the include_path ot show in the library where squirrelmail runs from (usr/share/squirrelmail i guess)

Kind Regards
Morten
Reply With Quote
Sponsored Links
  #2  
Old 27th April 2012, 14:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Where is DB.php located?

Code:
updatedb
locate DB.php
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th April 2012, 19:51
morten44 morten44 is offline
Member
 
Join Date: Apr 2012
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi
Thanks for comming back to me

I ran the command and this is the output:

/usr/share/php/DB.php
/usr/share/php/Auth/Container/DB.php
/usr/share/php/Auth/Container/MDB.php
/usr/share/php/PEAR/DependencyDB.php


Kind Regards
Morten
Reply With Quote
  #4  
Old 28th April 2012, 10:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

I think you need to add /usr/share/php to the open_basedir setting.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 28th April 2012, 15:13
morten44 morten44 is offline
Member
 
Join Date: Apr 2012
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi
Thanks for reply
I did that and still no Joy
I added them to open_basedir in Ispconfig under the customer
In the php.ini file its commended out.
Is that correct?

anything else I can check?

Regards Morten
Reply With Quote
  #6  
Old 30th April 2012, 02:52
morten44 morten44 is offline
Member
 
Join Date: Apr 2012
Posts: 37
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Hi
This resolved the problem
http://ubuntuforums.org/showthread.php?t=1948259

kind Regards
Morten
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
update services on ubuntu kwickcut HOWTO-Related Questions 3 12th February 2011 02:45
Install Fedora12 in VMware and bypass easy install tosmith1 Installation/Configuration 0 24th December 2010 19:26
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 10:53
problem install perl modules Cirox Installation/Configuration 10 16th May 2007 17:04
/usr/bin/make install install HTML::Parser -- NOT OK oddo Installation/Configuration 4 14th March 2006 19:32


All times are GMT +2. The time now is 22:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.