Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 16th November 2011, 15:20
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Default Same problem too...

Users receive mail fine. They can send from webmail, but not from mail client.

Code:
root@mail:~# updatedb
root@mail:~# locate smtpd.conf
/etc/postfix/sasl/smtpd.conf
/usr/lib/sasl2/smtpd.conf
/etc/default/saslauthd has:

Code:
OPTIONS="-c -m /var/run/saslauthd"
but...

Code:
root@mail:~# updatedb
root@mail:~# locate saslauthd
/etc/default/saslauthd
/etc/default/saslauthd.dpkg-old
/etc/default/saslauthd~
/etc/init.d/saslauthd
/etc/init.d/saslauthd.dpkg-old
/etc/rc1.d/K20saslauthd
/etc/rc2.d/S20saslauthd
/etc/rc3.d/S20saslauthd
/etc/rc4.d/S20saslauthd
/etc/rc5.d/S20saslauthd
/usr/sbin/saslauthd
/usr/sbin/testsaslauthd
/usr/share/man/man8/saslauthd.8.gz
/usr/share/man/man8/testsaslauthd.8.gz
/var/lib/update-rc.d/saslauthd
Of course changing it to:

Code:
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"
...and restarting after the change didn't help either.

I also installed the suggested versions of:

libsasl2-2_2.1.23.dfsg1-5ubuntu3_i386.deb
libsasl2-modules_2.1.23.dfsg1-5ubuntu3_i386.deb
libsasl2-modules-sql_2.1.23.dfsg1-5ubuntu3_i386.deb
libsasl2-dev_2.1.23.dfsg1-5ubuntu3_i386.deb
sasl2-bin_2.1.23.dfsg1-5ubuntu3_i386.deb

...still, no go:

Code:
Nov 16 16:13:03 mail postfix/smtpd[2916]: connect from some.one.provider.net[123.45.67.89]
Nov 16 16:13:04 mail postfix/smtpd[2916]: warning: SASL authentication failure: Password verification failed
Nov 16 16:13:04 mail postfix/smtpd[2916]: warning: some.one.provider.net[123.45.67.89]: SASL PLAIN authentication failed: authentication failure
Nov 16 16:13:04 mail postfix/smtpd[2916]: warning: some.one.provider.net[123.45.67.89]: SASL LOGIN authentication failed: authentication failure
Nov 16 16:14:05 mail postfix/smtpd[2916]: disconnect from some.one.provider.net[123.45.67.89]
What should I do to troubleshoot this further??
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
Sponsored Links
  #32  
Old 17th November 2011, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you use this guide? http://www.howtoforge.com/ubuntu-11....nism-available
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #33  
Old 17th November 2011, 17:35
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Default Yes, I tried that...

Yes, I tried that before I posted my question. I mention this in my post.

This is my /etc/postfix/sasl/smtpd.conf :

Code:
pwcheck_method: saslauthd
mech_list: plain login pam
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: ispconfig
sql_passwd: [some_hashed_password_string]
sql_database: dbispconfig
sql_select: select password from mail_user where email = '%u'
Does this seem right? (I've added the "pam" as one user has suggested)
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
  #34  
Old 18th November 2011, 10:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

The link I posted should wirk without any modifications to the guide. Maybe it's an i386 specific problem (because I tested on x86_64).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #35  
Old 18th November 2011, 15:08
klonos klonos is offline
Member
 
Join Date: Apr 2007
Posts: 78
Thanks: 5
Thanked 3 Times in 3 Posts
Question ok then...

...if you see no other way to troubleshoot this (I don't want to have you going and testing this in x86), could you then help me through moving this really old installation (ispconfig2 that was updated to ispconfig3) to a perfect server setup in a x64 environment?

We no longer need the ISP part of this server and would love to migrate to a simple, mysql-driven, single-domain installation keeping all users, passwords and stored mail too. Is there a guide available for this?

I was thinking to go with Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 11.10)
__________________
You can support Howtoforge and all the people behind it too. Consider becoming a supporter. It only costs a few and has to offer so much more than it already does. Take a look here
Reply With Quote
  #36  
Old 6th March 2012, 18:12
basmevissen basmevissen is offline
Junior Member
 
Join Date: Sep 2009
Posts: 10
Thanks: 3
Thanked 1 Time in 1 Post
Default

Hi Falko,

I've finally managed to get sasl2 working with the package supplied with Ubuntu 11.10. I think this is a better solution than using older sasl2 packages.
See https://bugs.launchpad.net/ubuntu/+s...40/comments/34 for more details.

Code:
$ cat /etc/postfix/sasl/smtpd.conf

pwcheck_method: saslauthd
mech_list: plain login pam
allow_plaintext: true
auxprop_plugin: sql
sql_engine: mysql
sql_hostnames: 127.0.0.1
sql_user: ispconfig
sql_passwd: ******************************
sql_database: dbispconfig
sql_select: select password from mail_user where email = '%u@%r'
Code:
$ cat /etc/default/saslauthd | grep -v ^\#

START=yes
DESC="SASL Authentication Daemon"
NAME="saslauthd"
MECHANISMS="pam"
MECH_OPTIONS=""
THREADS=0
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
This seems to be fine. I only think the SQL query needs modification to take the "disablesmtp" field into account.

I also added "pam" to mech_list to see if local user accounts could be used to authenticate for SMTP. Not tested yet.

Last edited by basmevissen; 6th March 2012 at 18:23.
Reply With Quote
The Following User Says Thank You to basmevissen For This Useful Post:
falko (7th March 2012)
  #37  
Old 28th April 2012, 14:02
petzsch petzsch is offline
Junior Member
 
Join Date: Jul 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I came accros this problem when installing on Ubuntu 12.04 and would like to see the changes proposed by basmevissen in the next release, when Ubuntu >= 11.10 is detected by the ISPConfig installer script.

Downgrading to an older sasl version as proposed in the "The Perfect Server - Ubuntu 11.10 [ISPConfig 3] - Page 4" howto, seems to be less desireable.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40


All times are GMT +2. The time now is 12:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.