Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd September 2011, 15:37
andyace andyace is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default ISPCONFIG3 Centos5 php 5.3 pear problem

Hi
I am hosting a new website for a company, the website has been transferred to us from another hosting company. and uses pear for mail
We have ispconfig3 running on centos5 php 5.3 and typically use postfix for all other mail websites which works fine.
i have yum installed pear and it works from the cli, the website throws a 500 error when the page with the pear mail reference loads, if i copy the pear mail folder to the website pagem, the page loads and pear works, i have set the path .:/usr/share/pear etc in php.ini and have set the vhost path and recreated the website vhost and copied the files back, still no luck, im guessing its a pathing or rights issue, do i need to set an allow directive to the usr/share/pear folder somewhere? also i cant see any log files with any relevant errors in.

thanks for checking my thread.

Andy
Reply With Quote
Sponsored Links
  #2  
Old 3rd September 2011, 12:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you check Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th September 2011, 18:08
andyace andyace is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

HI
Yep nothing in error_log in httpd, apart from some xend shell errors and timezone set incorrectly for some sites.
Reply With Quote
  #4  
Old 5th September 2011, 23:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

You can find the exact error message in the error.log of the website. Dont llok in the global error.log, use the error.log of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th September 2011, 23:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

And please do not post duplicate threads!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 5th September 2011, 23:43
andyace andyace is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi

Sorry about the double post i found this forum was more specific to the problem

In the php page if i hash out the 2 mail.php calls the page loads but the email function on the page doesn't work

# GET PEAR FUNCTIONS
# ("Mail.php");
# ("Mail/mime.php");

If i remove the hashes the page gets this error

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

and all i get this (i think unrelated) error in the websites error log

[Mon Sep 05 21:26:43 2011] [warn] mod_fcgid: stderr: PHP Warning: date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/London' for 'BST/1.0/DST' instead in /var/www/clients/client21/web90/web/destinations/index.php on line 182

if i copy all the pear folders and files from the /usr/share/pear folder to the website directory that this php file is being called from it all works but isn't very practical

Thanks

Andy
Reply With Quote
  #7  
Old 6th September 2011, 11:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

I think you need to add /usr/share/pear to your OpenBasedir directories in ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 6th September 2011, 12:55
andyace andyace is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

thanks
I have added the PEAR path in the ispconfig openbasedir tab on this websites config, tentatively it seems to be ok.

will report back when i have removed all the pear folders splattered all over the website.

Thanks So Far So Good

Last edited by andyace; 6th September 2011 at 13:10.
Reply With Quote
  #9  
Old 6th September 2011, 22:59
andyace andyace is offline
Junior Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

That fixed it, easy when your led in the right direction, hope this helps someone else.

Thanks Again

Andy
Reply With Quote
The Following User Says Thank You to andyace For This Useful Post:
falko (7th September 2011)
  #10  
Old 26th April 2012, 22:05
rsonline rsonline is offline
Junior Member
 
Join Date: Dec 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

It's helps me
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 6.0 support Acid_Scorpion Developers' Forum 47 16th September 2011 11:36
ISPConfig3 - Sending emails using PHP and Pear DKLeader Installation/Configuration 13 17th October 2010 16:14
Cannot add Mailboxes after PHP-Update hfr Installation/Configuration 5 7th November 2009 21:09
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
Newly Installed ISPConfig3 on Ubuntu 8.04 : login redirect fail ? cripperz Installation/Configuration 5 22nd March 2009 13:15


All times are GMT +2. The time now is 16:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.