Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd April 2012, 18:01
sumfvm sumfvm is offline
HowtoForge Supporter
 
Join Date: Sep 2011
Location: Strasbourg, France
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
Default I delete Apache2's modules dir...

Hi all,

I fail with a miss "rm -rf modules" in /usr/lib/apache2 folder.

To repair, I simply cp modules from another server and I reinstall the missing one through "aptitude reinstall libapache2-mod-suphp libapache2-mod-suphp libapache2-mod-fcgid libapache2-mod-passenger" but there is still problem.

All the websites are fully functional (with their respective databases) but ISPconfig admin panel and PhpMyAdmin produce error 500 with:

Quote:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mysql.so' - /usr/lib/php5/20090626/mysql.so: undefined symbol: _mysqlnd_fetch_lengths in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/mysqli.so' - /usr/lib/php5/20090626/mysqli.so: undefined symbol: mysqlnd_get_client_version in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/pdo_mysql.so' - /usr/lib/php5/20090626/pdo_mysql.so: undefined symbol: mysqlnd_allocator in Unknown on line 0
[Mon Apr 23 17:36:53 2012] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.2-1ubuntu4.14 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.14 OpenSSL/0.9.8o configured -- resuming normal operations
[Mon Apr 23 17:36:56 2012] [error] [client 82.244.34.64] PHP Fatal error: Call to undefined function mysql_connect() in 17:40 23/04/2012 on line 76
mysql.so, mysqli.so and pdo_mysql.so still exists...

Any idea?

Regards,
Reply With Quote
Sponsored Links
  #2  
Old 23rd April 2012, 18:03
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 46 Times in 27 Posts
Default

Can you try to reinstall php5-mysql?

I think that will take care of it.
Reply With Quote
  #3  
Old 23rd April 2012, 18:06
sumfvm sumfvm is offline
HowtoForge Supporter
 
Join Date: Sep 2011
Location: Strasbourg, France
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by dclardy View Post
Can you try to reinstall php5-mysql?

I think that will take care of it.
Already done but it don't change anything...

Thank you

Note this is only the admin panel et phpmyadmin who meet a problem, the ~200 other websites with DB I host don't have any problem with their CMS...
Reply With Quote
  #4  
Old 23rd April 2012, 18:13
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 46 Times in 27 Posts
Default

Can you try to reinstall ISPConfig so that it can recreate the vhost for it?
Reply With Quote
  #5  
Old 23rd April 2012, 18:18
sumfvm sumfvm is offline
HowtoForge Supporter
 
Join Date: Sep 2011
Location: Strasbourg, France
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
Default

For information:

Quote:
php -v
PHP 5.3.10-1~dotdeb.1 with Suhosin-Patch (cli) (built: Feb 2 2012 23:28:08)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH
Quote:
php --ini
Configuration File (php.ini) Path: /etc/php5/cli
Loaded Configuration File: /etc/php5/cli/php.ini
Scan for additional .ini files in: /etc/php5/cli/conf.d
Additional .ini files parsed: /etc/php5/cli/conf.d/apc.ini,
/etc/php5/cli/conf.d/curl.ini,
/etc/php5/cli/conf.d/gd.ini,
/etc/php5/cli/conf.d/imagick.ini,
/etc/php5/cli/conf.d/imap.ini,
/etc/php5/cli/conf.d/mcrypt.ini,
/etc/php5/cli/conf.d/mysql.ini,
/etc/php5/cli/conf.d/mysqli.ini,
/etc/php5/cli/conf.d/pdo.ini,
/etc/php5/cli/conf.d/pdo_mysql.ini,
/etc/php5/cli/conf.d/suhosin.ini,
/etc/php5/cli/conf.d/uploadprogress.ini
Quote:
Originally Posted by dclardy View Post
Can you try to reinstall ISPConfig so that it can recreate the vhost for it?
Is it not tricky?
Reply With Quote
  #6  
Old 23rd April 2012, 18:19
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 46 Times in 27 Posts
Default

Nope. It takes just a few minutes. You essentially run a manual upgrade process.
Reply With Quote
  #7  
Old 23rd April 2012, 18:31
sumfvm sumfvm is offline
HowtoForge Supporter
 
Join Date: Sep 2011
Location: Strasbourg, France
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by dclardy View Post
Nope. It takes just a few minutes. You essentially run a manual upgrade process.
I do a manuel update (d/l of the last tar.gz and php updaate.php) and it changes anything...
Reply With Quote
  #8  
Old 23rd April 2012, 18:41
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 46 Times in 27 Posts
Default

Did you run these commands?

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php
Reply With Quote
  #9  
Old 23rd April 2012, 18:53
sumfvm sumfvm is offline
HowtoForge Supporter
 
Join Date: Sep 2011
Location: Strasbourg, France
Posts: 25
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by dclardy View Post
Did you run these commands?

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php
Yes.

Problem solved, I finaly do a "revert to snapshot", thanks ESXi, but my customers lost all the last 5 hours work they do... But it is a free service so...

Thank you.

It happends when I tried to install a simple plugin to Munin to see all vhost activity (documents, req,, traffic).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - back-res a Backup and Restore script go0ogl3 Plugins/Modules/Addons 210 14th April 2014 17:30
ISPConfig 3.0.3.3 Autoresponder, adding subdomain problem BlackHat Installation/Configuration 4 18th October 2011 14:24
CPU load locks up box. Apache or MYSQL related. crypted General 61 29th October 2010 22:16
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 05:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.