#1  
Old 10th April 2012, 17:16
sBuchi sBuchi is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS-zone doesn`t "lookup"

Hi

I`ve installed a ISPConfig3 single-server setup.
I configured everything as it was described in the manual.

But when i create a dns-zone, i can't connect to it with "NSLookup"

I created the dns zone "test12.at" with an A-record "www"

This is the answer from my NSLookup:

Query:All records (ALL):test12.at
Query refused due to local policy
Complete:NO_DATA test12.at

Query:All records (ALL):www.test12.at
Query refused due to local policy
Complete:NO_DATA www.test12.at

Query:Address (A):www.test12.at
Query refused due to local policy
Complete:NO_DATA www.test12.at


What can i do that it works?
Reply With Quote
Sponsored Links
  #2  
Old 11th April 2012, 19:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do

Code:
dig @localhost test12.at
and
Code:
dig @localhost www.test12.at
work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th April 2012, 11:30
sBuchi sBuchi is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

dig @localhost test1.at


; <<>> DiG 9.7.3 <<>> @localhost test1.at
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 7966
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;test1.at. IN A

;; AUTHORITY SECTION:
at. 10800 IN SOA dns.nic.at. domain-admin.univie.ac.at. 1334217600 10800 3600 604800 10800

;; Query time: 62 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Apr 12 11:17:28 2012
;; MSG SIZE rcvd: 93

dig @localhost www.test1.at


; <<>> DiG 9.7.3 <<>> @localhost www.test1.at
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 36544
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;www.test1.at. IN A

;; AUTHORITY SECTION:
at. 10800 IN SOA dns.nic.at. domain-admin.univie.ac.at. 1334217600 10800 3600 604800 10800

;; Query time: 27 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Apr 12 11:19:46 2012
;; MSG SIZE rcvd: 97

- - - - - -
xxx.xxx.35.176 is the server where i have installed the singleserver-setup. When i try it via remote from an other server, i get these two following answers:

root@node172:~# dig @xxx.xxx.35.176 test1.at

; <<>> DiG 9.7.3 <<>> @xxx.xxx.35.176 test1.at
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached


root@node172:~# dig @xxx.xxx.35.176 www.test1.at

; <<>> DiG 9.7.3 <<>> @xxx.xxx.35.176 www.test1.at
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached
Reply With Quote
  #4  
Old 13th April 2012, 09:48
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Well did you check if your dns server is working properly on the local host as "NXDOMAIN" in your dig output indicates, that it did not find anything.

Regarding the ouput from the internet, did you check if the dns service is reachable from outside? (Firewall / ACL of bind blocking the access, bind listening on the localhost interface, only, check with netstat -tap)
Reply With Quote
  #5  
Old 16th April 2012, 22:09
nowhere nowhere is offline
Junior Member
 
Join Date: Apr 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Problem solved

Hi, I am also working on this installation.

node174 is a member of a 4 server installation with ISPConfig.
node174 is a DNS Server only
host120 is the second DNS Server


root@node174:~# netstat -tap | grep domain
tcp 0 0 node174.domain.tld:domain *:* LISTEN 26926/named
tcp 0 0 localhost:domain *:* LISTEN 26926/named
tcp 0 0 node174.domain.tld:domain node174.domain.tld:43194 TIME_WAIT -
root@node174:~#
root@node174:~# telnet node174.domain.tld 53
Trying xxx.xxx.35.174...
Connected to node174.domain.tld.
Escape character is '^]'.
Connection closed by foreign host.
root@node174:~#

So, bind is up and running.
If I look at /etc/bind there are all files, zone files and so on.
If I create a new zone at ISPConfig the zone file will also created at the /etc/bind directory.
The named.conf.local file contains all zones which are activated at ISPConfig

f.e.

zone "test.at" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.test.at";
} ;


root@node174:/etc/bind# /etc/init.d/bind9 status
bind9 is running.
root@node174:/etc/bind#

root@node174:/etc/bind# named-checkconf /etc/bind/named.conf
root@node174:/etc/bind#

-> no error

After them I checked if the zone files are OK:
named-checkzone localhost /etc/bind/pri.domain.tld

There are some "ignoring out-of-zone data" messages.
After them I deleted all zones and created them from the scratch.

Now, for the first view it looks like that it works.

Thank you for your support
Reply With Quote
Reply

Bookmarks

Tags
dns, dns-zone, lookup, record

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind9 failed to start after server restart laptop_user Installation/Configuration 2 1st October 2011 10:35
New domains not added to Bind9 DNS DKLeader Installation/Configuration 15 15th January 2011 21:11
HELP DNS and DHCP I AM LOST krisarmstrong Server Operation 0 18th August 2009 23:27
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Zone Transfer not complete. joelee HOWTO-Related Questions 3 19th August 2007 14:55


All times are GMT +2. The time now is 04:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.