Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2012, 11:15
andyb2000 andyb2000 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Emails causing Unable to create a dot-lock file

Hi folks,

This may just be a logical error that I've done, if so please point me in the right direction!

I've got quite a few domains attached to my Email setup, so my setup is:

Under Email Accounts > Domain I have the primary domain setup "example.com"
I then setup an Email mailbox "andy@example.com".
I then setup a Domain Alias for "@example.co.uk" forwarding to "@example.com".

So emails work if sent to andy@example.com or andy@example.co.uk. The problem comes if somebody sends an email to "fred@example.co.uk", the alias works and it tries to forward it to the example.com, but because fred@example.com doesn't exist (and I don't want it to exist!) it causes maildrop to get angry:

Code:
E29691036B1     2732 Sun Apr 15 18:14:59  fred@example.co.uk
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/example.com/fred/10677.0.vhost.)
                                         fred@example.com
Is there a simple solution to this, should I be creating a dummy catch-all to drop the mail or something, ideally I want these emails bounced with invalid recipient.

Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 16th April 2012, 11:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

The above message is ok, its the rejection of the email by maildrop for non existing accounts.

If you want that the emails for non existing accounts get denied by postfix directky and not maildrop, then remove the domain alias and replace it with email aliases of the email addresses that shall be forwarded.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th April 2012, 11:46
andyb2000 andyb2000 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the confirmation.

I understand the error, but I think i'll change it over to email aliases as at the moment these emails get stuck in my postqueue for the maximum time until they get attempted to return to sender with an error in delivery (untidy, as the sender doesn't get an immediate bounce, they get a delay then an error not an invalid sender return).
Reply With Quote
  #4  
Old 3rd July 2012, 01:15
gondim gondim is offline
Junior Member
 
Join Date: Jun 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi

I have this error:

052FA5C09E5 36040 Mon Jul 2 19:56:15 wesley.costa@correiasmercurio.com.br
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
vendas3@rscomercial.ind.br

04B875C062D 57768 Mon Jul 2 19:50:53 teste@intnet.com.br
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
gondim@rscomercial.ind.br
Reply With Quote
Reply

Bookmarks

Tags
alias, domain, maildrop

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
ISPConfig 3.0.3.3 Autoresponder, adding subdomain problem BlackHat Installation/Configuration 4 18th October 2011 14:24
Cron issue in Debian 6 Nolan Installation/Configuration 6 18th April 2011 16:36
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
rewrite url not work apache2+mod_rewrite mohamedtah Installation/Configuration 1 31st January 2009 13:00


All times are GMT +2. The time now is 16:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.