#1  
Old 11th April 2012, 19:15
beenfishing beenfishing is offline
Member
 
Join Date: Jan 2010
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Default DNS Problem

I have setup a multiserver following the Debian Squeeze guide, everything appears to be setup correctly except for the DNS.

I have made my domain at GoDaddy use my dns servers without any problems nut I am unable to ping my domain.

What I have noticed through if I look at the bind configs via terminal, both are set as master and use the same IP.

I have told DNS2 to be a mirror of DNS1 via the ISPconfig wen interface.

Please could some one point me in the right direction.

Here is a brief overview of my system.

Webserver and CP = 196.213.171.1 (example)
Mail server = 196.213.171.2 (example)
DB Server = 196.213.171.3 (example)
DNS1 = 196.213.171.4 (example)
DNS2 = 196.213.171.5 (example)

DNS1 Named.conf.local file

zone "ofthesea.net" {
type master;
allow-transfer {41.76.212.98;};
file "/etc/bind/pri.ofthesea.net";

DNS2 Named.conf.local file

zone "ofthesea.net" {
type master;
allow-transfer {41.76.212.98;};
file "/etc/bind/pri.ofthesea.net";
};

By looking at this it looks as if they are both acting as the master, how do I fix my setup?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 11th April 2012, 19:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

Your setup is fine, dns records are mirrored by ispconfig so both bind servers have to act as master and your config files show that it woks as expected. The problem that you can not ping your domain has a different reason, please post the content of the file /etc/bind/pri.ofthesea.net from one of your servers.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th April 2012, 20:07
beenfishing beenfishing is offline
Member
 
Join Date: Jan 2010
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Default DNS Problem

Thanks so much for you speedy reply.

I have removed the DNS record and added it again.

Please see below

DNS1

zone "ofthesea.net" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.ofthesea.net";

DNS2


zone "ofthesea.net" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.ofthesea.net";
};

pri.ofthesea.net

@ IN SOA tuna.ofthesea.net. postmaster.ofthesea.net. (
2012041103 ; serial, todays date + todays serial #
7200 ; refresh, seconds
540 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

mail 3600 A 41.76.212.92
ofthesea.net. 3600 A 41.76.212.92
ofthesea.net. 3600 MX 10 mail.ofthesea.net.
ofthesea.net. 3600 NS tuna.ofthesea.net.
ofthesea.net. 3600 NS yellowtail.ofthesea.net.
www 3600 A 41.76.212.92
Reply With Quote
  #4  
Old 12th April 2012, 08:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

The dns servers of the domain ofthesea.net are subdomains of the same domain, in such a case you have to add dns glue records in the dns server of the domain registry or in your case in the godaddy dns interface:

http://en.wikipedia.org/wiki/Glue_re...d_glue_records

So the dns setup on your server is fine, its just a externalproblem that you have to fix at godaddy by adding glue records for tuna.ofthesea.net and yellowtail.ofthesea.net
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 12th April 2012, 10:29
beenfishing beenfishing is offline
Member
 
Join Date: Jan 2010
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Default DNS Problems

I've done the correct setup at godaddy i think.

I've attached a screenshot of my GoDaddy config.

Really at a dead end here, can't seem to get this right.
Attached Images
 
Reply With Quote
  #6  
Old 14th April 2012, 15:06
beenfishing beenfishing is offline
Member
 
Join Date: Jan 2010
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Default DNS Problem

Still battling with this if anyone has any suggestions.

Just some more info.

Output of "dig ofthesea.net" on tuna (dns1)


; <<>> DiG 9.7.0-P1 <<>> ofthesea.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 42704
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ofthesea.net. IN A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sat Apr 14 15:00:42 2012
;; MSG SIZE rcvd: 30


Output of intodns.com

http://www.intodns.com/ofthesea.net

Please if anyone has any suggestions, I would be truly grateful.
Reply With Quote
  #7  
Old 15th April 2012, 11:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Did you create A records for tuna.ofthesea.net and yellowtail.ofthesea.net? Did oyu create NS records with tuna.ofthesea.net and yellowtail.ofthesea.net in your zone?

Also, the glue records still seem to be missing. Unfortunately, I cannot help you with the GoDaddy interface because I don't use it myself. Maybe you should contact their support.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major recovery Toucan Installation/Configuration 18 9th August 2011 11:45
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Problem in DNS createch Installation/Configuration 1 2nd April 2010 13:18
Slave dns problem blackmask Installation/Configuration 1 3rd October 2007 13:51
DNS issue and user's alias problem rosa hsiao General 3 2nd November 2005 10:03


All times are GMT +2. The time now is 00:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.