Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 6th April 2012, 11:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I've added this to our bugtracker, so we will check that.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 6th April 2012, 12:10
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Thanks falko. I'm looking forward for any news.
Reply With Quote
  #13  
Old 7th April 2012, 04:05
Lontro Lontro is offline
Junior Member
 
Join Date: Apr 2012
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello,

I can confirm that with ISPConfig 3.0.4.3 the mm_cfg.py template /usr/local/ispconfig/server/conf/mm_cfg.py.master is not copied into /etc/mailman/ correctly and it creates an empty mm_cfg.py for mailman.

This results into a mailman without functionality.
ISPconfig system logging in Debug does not show any informations usable just that it processed the datalog_id.

Changing the line 116 in /usr/local/ispconfig/server/plugins-enabled/mailman_plugin

from

if(file_exists($conf["rootpath"]."/conf/mm_cfg.py.master")) {

to

if(file_exists($conf["rootpath"]."/conf-custom/mm_cfg.py.master")) {

resolves the problem.
Regards

Last edited by Lontro; 7th April 2012 at 04:36.
Reply With Quote
The Following User Says Thank You to Lontro For This Useful Post:
baskin (7th April 2012)
  #14  
Old 7th April 2012, 09:04
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Thanks Lontro.

What i have to do after editing the file?
Reply With Quote
  #15  
Old 7th April 2012, 10:43
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

I can confirm that Lontro's solution makes mailman to restart successfully.

I although still getting 404 not found on admin and info urls of the list.

Also no mail has been sent with the creation of the list.
Reply With Quote
  #16  
Old 10th April 2012, 01:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I've just tested, and it works for me. Please disable CGI for the website and try again.

Quote:
Also no mail has been sent with the creation of the list.
Please check your mail log for errors.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
baskin (10th April 2012)
  #17  
Old 10th April 2012, 09:32
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Thanks falko. After applying the patch and disabling cgi for the vhost, mailman is working!!!

Should this info be applied to the manual?
Reply With Quote
  #18  
Old 10th April 2012, 12:21
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Another issue is that archiving doesn't work with the following error:

Code:
Apr 10 12:15:23 2012 (17078) Archive file access failure:
        /var/lib/mailman/archives/private/it.mbox/it.mbox [Errno 13] Permission denied: '/var/lib/mailman/archives/private/it.mbox/it.mbox'
Apr 10 12:15:23 2012 (17078) Uncaught runner exception: [Errno 13] Permission denied: '/var/lib/mailman/archives/private/it.mbox/it.mbox'
Apr 10 12:15:23 2012 (17078) Traceback (most recent call last):
  File "/var/lib/mailman/Mailman/Queue/Runner.py", line 120, in _oneloop
    self._onefile(msg, msgdata)
  File "/var/lib/mailman/Mailman/Queue/Runner.py", line 191, in _onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/var/lib/mailman/Mailman/Queue/ArchRunner.py", line 73, in _dispose
    mlist.ArchiveMail(msg)
  File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 198, in ArchiveMail
    self.__archive_to_mbox(msg)
  File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 167, in __archive_to_mbox
    mbox = self.__archive_file(afn)
  File "/var/lib/mailman/Mailman/Archiver/Archiver.py", line 155, in __archive_file
    return Mailbox.Mailbox(open(afn, 'a+'))
IOError: [Errno 13] Permission denied: '/var/lib/mailman/archives/private/it.mbox/it.mbox'
I can see that is a permission error. Which permission settings have to be set and on which folder, for the other future lists to work as well?

Thank you in advance.
Reply With Quote
  #19  
Old 10th April 2012, 12:33
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
 
Default

Running

Code:
chown -R list private/
in /var/lib/mailman/archives, solved the issue.
Reply With Quote
The Following User Says Thank You to baskin For This Useful Post:
falko (11th April 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Installation problem - WARNING: Could not unpack ISPConfig system?!? darko Installation/Configuration 3 19th July 2009 18:43
Problem with my ISPconfig installation Purposite Installation/Configuration 2 13th June 2009 18:54
ISPconfig Virtual Hosts + Perfect setup Problem ? orasis Installation/Configuration 5 16th March 2007 10:46


All times are GMT +2. The time now is 14:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.