#1  
Old 9th April 2012, 01:23
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default Sendmail stops working

Hi there,

After a couple of weeks of not receiving any emails sent from a web-based contact form ("doh!"), sendmail appears to have stopped working.

From the mail log:
(!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused, retrying (2)

Restarting ClamAV fixes the issue:

/etc/init.d/amavis restart

... However I'd like to find out what's causing this, as it has happened a number of times over the last 6 months.

Is the below related?
  • Under ISPConfig admin interface > Monitor, I get: Your virus protection is OUTDATED!
  • My ClamAV log (as shown in ISPConfig) is empty
  • My FreshClam shows:

    Sun Apr 8 19:25:45 2012 -> DON'T PANIC! Read http://www.clamav.net/support/faq
    Sun Apr 8 19:25:45 2012 -> bytecode.cld is up to date (version: 168, sigs: 38, f-level: 63, builder: edwin)
    Sun Apr 8 19:25:45 2012 -> WARNING: Current functionality level = 62, recommended = 63
    Sun Apr 8 19:25:45 2012 -> Please check if ClamAV tools are linked against the proper version of libclamav
    Sun Apr 8 19:25:45 2012 -> DON'T PANIC! Read http://www.clamav.net/support/faq
    Sun Apr 8 19:25:45 2012 -> [LibClamAV] ************************************************** *********
    Sun Apr 8 19:25:45 2012 -> [LibClamAV] *** This version of the ClamAV engine is outdated. ***
    Sun Apr 8 19:25:45 2012 -> [LibClamAV] *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    Sun Apr 8 19:25:45 2012 -> [LibClamAV] ************************************************** *********

Is there something I should be doing?

Please help!
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2012, 12:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

If you're using ISPConfig 3, you should have Postfix installed instead of Sendmail. What's in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th April 2012, 22:22
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Hey Falko, thanks for the response.

You are right, I didn't mean Sendmail.

I included the pertinent line from my mail log above, but here it is again:

(!)ClamAV-clamd: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused, retrying (2)

Would you mind weighing-in again?

Thanks!

Mat

Last edited by msp; 15th April 2012 at 22:24.
Reply With Quote
  #4  
Old 16th April 2012, 10:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Does /var/run/clamav/clamd.ctl exist? You can check with
Code:
ls -la /var/run/clamav/clamd.ctl
If not, does it exist after
Code:
/etc/init.d/amavis restart
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th April 2012, 12:10
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Hi, yes /var/run/clamav/clamd.ctl does exist.

At the moment mail is sending okay, it's just that it periodically stops. This could be every few months even. The problem is that I don't know of any way of monitoring it.

The problem is that if messages don't send, I don't get business enquiries, which is my primary income
Reply With Quote
  #6  
Old 16th April 2012, 16:44
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,145
Thanks: 4
Thanked 55 Times in 51 Posts
Default

You can use "monit" to monitor the process.
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #7  
Old 17th August 2012, 15:30
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default

I've installed monit, and looked through its documentation, but my one issue is this:

It appears monit uses the local mailserver to send email in the event of a problem.

The thing I need to monitor is the local mailserver itself, as that's the thing that is failing!

So I don't think using monit will work.

Can anyone help me? Why do I need to periodically manually restart clamav to make mail send?!
Reply With Quote
  #8  
Old 18th August 2012, 12:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by msp View Post
So I don't think using monit will work.
But you can at least use monit to restart the mail server if it fails.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
clam, mail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Memory] No more availeble, server stops working J0s3ph General 1 20th February 2011 23:23
debian network stops working suddenly Croydon Server Operation 2 15th March 2010 12:54
Sendmail to local domain ignoring MX records FractalizeR Installation/Configuration 6 20th January 2010 13:17
dk-filter / sendmail / centos ALMOST working but broken pipe to socket? Please help kinesis Installation/Configuration 4 6th April 2009 20:54
sendmail not working with PHP wintertong Server Operation 17 27th February 2009 11:38


All times are GMT +2. The time now is 11:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.