Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th April 2012, 18:18
pont pont is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default www.site.com and site.com redirect to different roots

Hi,

I installed ISPConfig 3 on Ubuntu 10.04 following The Perfect Server.

Everything is working all right BUT
the only issue is that when I type site.com it goes to ISPConfig created Site -> /var/www/site.com/web , when I type www.site.com it goes to apache default page ->/var/www

My DNS records are as follows:

Server: server.site.com
Zone (SOA): site.com.
ns: ns1.site.com.
email: email.gmail.com.

Type Name Data Priority
A mail 192.168.0.1 0
A ns1 192.168.0.1 0
A ns2 192.168.0.1 0
A site.com. 192.168.0.1 0
A www 192.168.0.1 0
MX site.com. mail.site.com. 10
NS site.com. ns1.site.com. 0
NS site.com. ns2.site.com. 0

My Site Web Domain Configuration is:

Server: server.site.com
IPv4: *
Domain: site.com
Harddisk quota: -1
Traffik quota: -1
CGI: -
SSI: -
Ruby: -
Python: -
SuEXEC: checked
Own ErrorPages: checked
Auto-Subdomain: None
SSL: -
PHP: Fast-CGI
Active: checked

Redirects: No redirect set to both

I intend to use with Symfony2

So am I doing wrong in DNS and Sites or missing anything ???
Reply With Quote
Sponsored Links
  #2  
Old 8th April 2012, 10:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by pont View Post
Auto-Subdomain: None
Select www or *.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd July 2012, 19:16
pont pont is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Select www or *.
I tried both of them but neither helped.

I'm also having 403 Forbidden Status. Site loads all well but with status 403.
apache error_log says: Directory Indexing forbidden.

I didn't want to change manually in sites-available/.conf files.

what would you be suggesting????
Reply With Quote
  #4  
Old 3rd July 2012, 08:48
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,750
Thanks: 821
Thanked 5,329 Times in 4,181 Posts
Default

You have to select Auto subdomain: www" to point site.com and www.site.com to the same website. If you select auto subdomain none, then apache does not know that www.domain.com exists and will route the traffic to the default site.

Also ensure that you select the IP address and not * in the IPv4 field.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th July 2012, 07:20
pont pont is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Also ensure that you select the IP address and not * in the IPv4 field.
Hi till,

I only got * in IPv4 field. I don't have IP address. I am considering directly modifying .vhost files. ISPConfig has problems apparently.
Reply With Quote
  #6  
Old 5th July 2012, 09:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,750
Thanks: 821
Thanked 5,329 Times in 4,181 Posts
 
Default

Quote:
I am considering directly modifying .vhost files.
Thats a bad idea as your changes will be removed automatically anyway.

The correct solution is to add the IP under System > Server IP and then select it in the website settings.

Quote:
ISPConfig has problems apparently.
No, you just missed to add your IP address in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.