Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th April 2012, 12:49
haluk yildirim haluk yildirim is offline
Junior Member
 
Join Date: Jan 2012
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default BackupPC "500 server error" and "command not in docroot "

Hi,

I have several ISPConfig 3 on Fedora 14 installations at my customer base. All works very nicely. Recently I have started to install BackupPC which I have used with fedora installations without any problem. But now, after clean ISPConfig 3 Install I get "500 Internal Server Error" with "command not in docroot (/usr/share/BackupPC/sbin/BackupPC_Admin)" error in suexec.log

suexec -V
-D AP_DOC_ROOT="/var/www"
-D AP_GID_MIN=100
-D AP_HTTPD_USER="apache"
-D AP_LOG_EXEC="/var/log/httpd/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=500
-D AP_USERDIR_SUFFIX="public_html"

suexec.log....

[2012-04-04 16:57:05]: uid: (5004/web1) gid: (5005/client1) cmd: BackupPC_Admin
[2012-04-04 16:57:05]: command not in docroot (/usr/share/BackupPC/sbin/BackupPC_Admin)


Not much luck from google. what am I doing wrong?

Last edited by haluk yildirim; 4th April 2012 at 14:30.
Reply With Quote
Sponsored Links
  #2  
Old 5th April 2012, 08:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

You receive the error because the site that you use to access backuppc uses suexec and the backuppc installation is outside of the apache docroot. Your other servers must have used mod_php or a similar setup without security checks if you did not had that problem before. Try to switch the php mode to mod_php in the website of the domain that you use to access backupPC.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
haluk yildirim (5th April 2012)
  #3  
Old 5th April 2012, 12:19
haluk yildirim haluk yildirim is offline
Junior Member
 
Join Date: Jan 2012
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

(SOLVED)

Hi Till,

Thank you for your quick reply.

I have disabled the suexec and enabled the MOD-PHP in ispconfig sites tab. and fixed the problem.

Again.. Thank you very much.

Haluk
Reply With Quote
Reply

Bookmarks

Tags
backuppc, command not in docroot, ispconfig 3, suexec

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.