Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th September 2010, 13:37
Ventzy Ventzy is offline
Junior Member
 
Join Date: Jan 2010
Posts: 17
Thanks: 2
Thanked 2 Times in 2 Posts
Default How to setup FTP over SSL/TLS in Pure-FTPd

I want all ftp connections to my server to be encrypted.

I found this http://www.howtoforge.com/forums/sho...81&postcount=3

But it gives me in FileZilla (on Vista):
Status: Connecting to IP:990...
Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server".
Plain FTP connection to the server is OK.

I read http://download.pureftpd.org/pub/pur...doc/README.TLS and it says that pure-ftpd daemon must be started with "--tls=2", but I am not sure how to setup that.

I am using Ubuntu 10.04 and ISPConfig 3.0.2.2

Thanks.

Last edited by Ventzy; 30th September 2010 at 13:40.
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2010, 16:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Maybe you can set this in the PureFTPd init script in /etc/init.d/.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th October 2010, 10:33
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default simmilar problem ...

hello
i have simmilar problem
im tryin to run pureftpd wiht TLS

on echo 1 error is
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (10,8,0,1,154,133)
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

debug info - Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [INFO] New connection from aaa.bbb.ccc.ddd
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [DEBUG] Command [user] [USER_1]
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [DEBUG] Command [pass] [<*>]
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [INFO] USER_1 is now logged in
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [opts] [UTF8 ON]
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [pwd] []
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [type] [I]
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [pasv] []
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [mlsd] []
Oct 5 11:36:28 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [INFO] Logout.


on echo 2 error is
Command: PASS *******************
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

debug info - [WARNING] Sorry, cleartext sessions are not accepted on this server.#012Please reconnect using SSL/TLS security mechanisms.


on echo 3 error is
Response: 421 Sorry, cleartext sessions are not accepted on this server.
Error: Could not connect to server

debug info - [WARNING] Sorry, cleartext sessions are not accepted on this server.#012Please reconnect using SSL/TLS security mechanisms.

for 2 and 3 TLS the error is expected ...

ftp client is FileZilla for windows ..
where i get wrong ?

Last edited by DUCKFACE; 5th October 2010 at 10:40.
Reply With Quote
  #4  
Old 6th October 2010, 14:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Do you use Debian or Ubuntu? If so, try this: http://www.howtoforge.com/forums/showthread.php?t=43509
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th October 2010, 08:13
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default I am using Ubuntu 10.04 and ISPConfig 3.0.2.2

I am using Ubuntu 10.04 and ISPConfig 3.0.2.2

I have done the settings and ftp server is running with TLS but when i try to login i have this :
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [INFO] New connection from aaa.bbb.ccc.ddd
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [DEBUG] Command [user] [USER_1]
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [DEBUG] Command [pass] [<*>]
Oct 5 11:36:07 server pure-ftpd: (?@aaa.bbb.ccc.ddd) [INFO] USER_1 is now logged in
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [opts] [UTF8 ON]
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [pwd] []
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [type] [I]
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [pasv] []
Oct 5 11:36:07 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [DEBUG] Command [mlsd] []
Oct 5 11:36:28 server pure-ftpd: (USER_1@aaa.bbb.ccc.ddd) [INFO] Logout.

means auth is ok ... ssl is ok ... but somethin in Error: Connection timed out

any ideas
Reply With Quote
  #6  
Old 10th October 2010, 19:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Please try this: http://www.howtoforge.com/how-to-con...n-debian-lenny
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th January 2012, 23:56
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 24 Times in 14 Posts
Default

Hello,

i have the same problem and retry setup with 2 or 1 in config form ftp and restart and new cert wont help!

Problem found: Firewall in ISPConfig -> You need more Ports

regards
xaver

Last edited by xaver; 21st January 2012 at 00:11.
Reply With Quote
  #8  
Old 2nd April 2012, 15:55
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default ports ...

how we manage with that problem?
Reply With Quote
  #9  
Old 2nd April 2012, 17:16
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
 
Default

have a look at this post it may help

http://www.howtoforge.com/forums/showthread.php?t=56349
__________________
Operating system Ubuntu Linux 10.04.4
ISPConfig Version: 3.0.4.3
Webmin version 1.580
Kernel and CPU Linux 2.6.32-40-server on x86_64
Processor information AMD Phenom(tm) II X4 945 Processor, 4 cores
Real memory 4.0 GB total
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pure ftp -> ftps admins Installation/Configuration 1 17th September 2010 12:45
pure ftp sftp file count blocker General 1 9th February 2010 09:24
Website users? ctroyp General 25 6th January 2006 18:02
FTP 101 the basics koegies Installation/Configuration 7 17th November 2005 15:55
FTP access problem... ctroyp General 7 12th October 2005 17:07


All times are GMT +2. The time now is 15:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.