Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2012, 15:19
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 196
Thanks: 66
Thanked 13 Times in 11 Posts
Default Database remote access to all doesn't work

Hello,

I checked database remote access option and leave emtpy IP's input field according to ispconfig manual:

To allow connections from all remote hosts, leave this field empty.

In phpMyAdmin privilegs tab nothing changed. I expected "%" value in host setting but "localhost" value remain. If I set specific IP host value is correctly set to this IP.

How can I set "%" through ISPConfig?

ISPConfig version: 3.0.4.3
OS: Ubuntu 10.04

SupuS
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2012, 15:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Quote:
How can I set "%" through ISPConfig?
Enable the remote access option in the mysql database settings.

Quote:
In phpMyAdmin privilegs tab nothing changed.
Either you did not wait until ispconfig has written the changes to the mysql priviliges table (see jobqueue in monitor tab) or the mysql root password has been changed so that the password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is wrong.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th February 2012, 15:32
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 196
Thanks: 66
Thanked 13 Times in 11 Posts
Default

Quote:
Originally Posted by till View Post
Enable the remote access option in the mysql database settings.



Either you did not wait until ispconfig has written the changes to the mysql priviliges table (see jobqueue in monitor tab) or the mysql root password has been changed so that the password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is wrong.
Thank you for replay but I probably not explain problem clearly. I have set what you wrote:

Code:
# netstat -tap |grep mysql
tcp        0      0 *:mysql                 *:*                     LISTEN      1197/mysqld
and yes I wait for more than one minute and checked jobqueue in monitor tab and my mysql root password is correct.

What I am reporting here is that remote access setting for all not work. Remote access works for specific IP only. May be a bug?

SupuS
Reply With Quote
  #4  
Old 27th February 2012, 15:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Quote:
What I am reporting here is that remote access setting for all not work. Remote access works for specific IP only. May be a bug?
It works fine here, just tested it in 3.0.4.3 On Debian 6. So if its a bug, then its not reproducable on Debian servers.

When I add a database with renote access enabled and a empty remote access IP field, ispconfig inserts a user and db record pair for localhost and a second user and db record pair for %.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th February 2012, 16:19
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 196
Thanks: 66
Thanked 13 Times in 11 Posts
Default

Quote:
Originally Posted by till View Post
It works fine here, just tested it in 3.0.4.3 On Debian 6. So if its a bug, then its not reproducable on Debian servers.

When I add a database with renote access enabled and a empty remote access IP field, ispconfig inserts a user and db record pair for localhost and a second user and db record pair for %.
I tested it on two Ubuntu 10.04 boxes and I found that remote access settings not work at all (IP for remote access on first server probably was added in previous ISPConfig version .. I don't know). When I check remote access nothing change in phpMyAdmin privilegs tab. When I check remote access and fill specific IP I see no changes again.

Messages in debug mode is not helpfull:

Code:
2012-27-02 15:14  www.example.com  Debug  Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
2012-27-02 15:14  www.example.com  Debug  Processed datalog_id 143
2012-27-02 15:14  www.example.com  Debug  Changing MySQL remote access privileges for database: cXXXXXXX
2012-27-02 15:14  www.example.com  Debug  Calling function 'db_update' from plugin 'mysql_clientdb_plugin' raised by event 'database_update'.
2012-27-02 15:14  www.example.com  Debug  Found 1 changes, starting update process.
2012-27-02 15:14  www.example.com  Debug  Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
Is there some more detailed log file? How I can find why it doesn't work?

SupuS
Reply With Quote
  #6  
Old 27th February 2012, 16:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Quote:
I tested it on two Ubuntu 10.04 boxes and I found that remote access settings not work at all (IP for remote access on first server probably was added in previous ISPConfig version .. I don't know).
Then you have most likely a problem with the mysql root password (the password in this file has to be the root password, not the ispconfig password and the name of the user must be "root"). Check the password in the mysql_clientdb.conf again by using this passwod to log into the database with the "mysql" commandline tool on "localhost".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 27th February 2012, 16:53
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 196
Thanks: 66
Thanked 13 Times in 11 Posts
Default

Quote:
Originally Posted by till View Post
Then you have most likely a problem with the mysql root password (the password in this file has to be the root password, not the ispconfig password and the name of the user must be "root"). Check the password in the mysql_clientdb.conf again by using this passwod to log into the database with the "mysql" commandline tool on "localhost".
As I said before .. settings in /usr/local/ispconfig/server/lib/mysql_clientdb.conf are correct. I tested it now by:

Code:
mysql -u root -p mysql
and it works fine.

SupuS
Reply With Quote
  #8  
Old 28th March 2012, 20:18
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 196
Thanks: 66
Thanked 13 Times in 11 Posts
Default

Please can somebody test adding permissions by ISPConfig on ubuntu 10.04 box? It still doesn't work on my servers
Reply With Quote
  #9  
Old 29th March 2012, 08:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

It works fine here on my servers with ISPConfig 3.0.4.3. Did you add the databases in ispconfig or with the remote api?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 29th March 2012, 10:41
SupuS SupuS is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 196
Thanks: 66
Thanked 13 Times in 11 Posts
 
Default

Quote:
Originally Posted by till View Post
It works fine here on my servers with ISPConfig 3.0.4.3. Did you add the databases in ispconfig or with the remote api?
I added database directly in ispconfig. Here is my procedure (directly in ISPConfig):

1) create database and safe database without remote access
2) edit database and allow remote access only
3) check database permission in phpMyAdmin => permission is for localhost only => remote access doesn't work
4) add permission manually in phpMyAdmin => remote access work as expected

In point 2 I can allow specific IP only and result is the same .. no changes in permissions at all.

SupuS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Database Remote Access Lionheart82 Installation/Configuration 4 6th March 2012 11:25
mandriva directory server on debian lenny maumar HOWTO-Related Questions 8 7th February 2010 01:58
Remote access to DB does not work mbogh Installation/Configuration 4 2nd September 2009 09:58
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
How To ACCESS MySQL DATABASE FROM PHP CODE FOR SQUIRRELMAIL SERVER Ghose Sumon HOWTO-Related Questions 1 21st May 2007 21:41


All times are GMT +2. The time now is 21:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.