#1  
Old 28th March 2012, 15:02
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 38
Thanked 90 Times in 68 Posts
Default ISPconfig monitor

Hello,

I'm using rescue in ispconfig but I found a problem with http monitoring.

access.log
Code:
127.0.0.1 - - [28/Mar/2012:15:00:01 +0200] "GET / HTTP/1.1" 403 277 "-" "Mozilla/5.0 (ISPConfig monitor)"
error.log
Code:
[Wed Mar 28 15:00:01 2012] [error] [client 127.0.0.1] client denied by server configuration: /htdocs
Any idea please?
Reply With Quote
Sponsored Links
  #2  
Old 28th March 2012, 15:06
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,485
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Seems as if you redirect requests to 127.0.0.1 in your apache to a non existing directory called htdocs and this triggers the error. Please check that the default vhost directory of your apache server exists and that it contains some kind of index file like index.html
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th March 2012, 16:00
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 38
Thanked 90 Times in 68 Posts
 
Default

Thank you Till,

I think you are right, default vhost was disabled time ago.

But /htdocs ? Default directory point to /var/www

Code:
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
more test, I did

Code:
root@server /etc/apache2 # grep -R htdocs *
with no results.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
No dns zone files created? sjau Installation/Configuration 7 13th March 2012 13:15
reinstall postfix after securing-short question fxs Installation/Configuration 12 30th January 2012 10:10
ISPConfig 3 Monitor Ajax Request was not successful sebastiaands Installation/Configuration 0 15th June 2010 15:04
ISPConfig 3: Monitor Module & Logfiles - All setup correctly? Master One Installation/Configuration 2 10th July 2009 18:51


All times are GMT +2. The time now is 15:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.