Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th March 2012, 03:00
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default PHP 5.4 problems

Hello,

i tested 5.4 a little bit and got some errors:
PHP Code:
Strict Standards:  Non-static method SimplePie_Misc::parse_date() should not be called staticallyassuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 60

Strict Standards
:  Non-static method SimplePie_Parse_Date::get() should not be called staticallyassuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php on line 10870 
i fixed some notice errors

regards
xaver
Reply With Quote
The Following User Says Thank You to xaver For This Useful Post:
till (20th March 2012)
Sponsored Links
  #2  
Old 20th March 2012, 08:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Have you tried to define both methods as static?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th March 2012, 09:58
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default

No, but i will look into it.

I fixed some other PHP 5.4 Notice Errors.
e.g.
if $conf['country'] is not defined and $conf = array() is defined it will drop an notice error if you use $conf['country']
i did s small if..
(isset($conf['country']) ? $conf['country'] : '')
Reply With Quote
  #4  
Old 20th March 2012, 12:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

I guess that there is a wrong variable used, the country settings in ISPConfig are in the variable $conf['language'] and not $conf['country'] (there is no separate contry setting available, so replacing the variable should fix the error.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th March 2012, 12:15
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default

Its in client and reseller in list. (My last commit)
Also i think it was readData witch had an error with readData['demo_viewmode']
or
Notice: Undefined variable: maintenance_mode_error in /usr/local/ispconfig/interface/web/login/index.php on line 238

Looks like each array element need a "isset() && condition(e.g. == != > <= ...)" the possibility exists its not set, because the element will be created.

I turned two functions into static functions and it looks like it works.

Last edited by xaver; 20th March 2012 at 12:22.
Reply With Quote
  #6  
Old 20th March 2012, 12:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Quote:
Notice: Undefined variable: maintenance_mode_error in /usr/local/ispconfig/interface/web/login/index.php on line 238
I fixed that in svn and changed the country setting to language.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd March 2012, 03:58
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default

Quote:
Originally Posted by brian1999 View Post
Its in client and reseller in list.
Sorry. i dont understand.

Last edited by till; 22nd March 2012 at 09:58.
Reply With Quote
  #8  
Old 22nd March 2012, 09:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

This was a spam post, I removed that now. I edited your post and removed the spam link that you quoted with his message
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 23rd March 2012, 06:41
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default

Oh i saw no link, maybe blocked by my Browser and addons.

i will commit simplepie with static functions. Looks like it works fine.

can you take a look at commit 3011? fixed a lot of stuff for php 5.4. (+ i think small bug -> see comment)

Last know errors are at FAQ management, but i think the problem is of the wrong use of list/template system.

mail_transport_edit and mail_user_edit have a lot of @. That is bad because if a real problem comes around you won't see it.
Reply With Quote
  #10  
Old 23rd March 2012, 10:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
 
Default

Quote:
i will commit simplepie with static functions. Looks like it works fine.
Thanks!

Quote:
can you take a look at commit 3011? fixed a lot of stuff for php 5.4. (+ i think small bug -> see comment)
Looks fine Thanks for fixing the php notices.

Quote:
Last know errors are at FAQ management, but i think the problem is of the wrong use of list/template system.
I guess we should consider to rewrite the faq module so that it uses the trmaplt system correctly. Might be cleaner then building workarounds to get the sorting functions to work with the current code.

Quote:
mail_transport_edit and mail_user_edit have a lot of @. That is bad because if a real problem comes around you won't see it.
That should be changed in the long term indeed. I made a todo item in the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 13:56
ubuntu and nginx delgado2061 Installation/Configuration 0 28th November 2011 00:36
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 04:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.