Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st March 2012, 21:17
xzibiz xzibiz is offline
Junior Member
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig 3 and secondary dns problems

Hi

I have an ISPconfig3 server running web, ftp, db, email and dns.
I've tried to follow guides on howto set up an secondary dns, ns2.
I think I've done it correct.

Code:
dig @ns1.domain.net any domain.com

; <<>> DiG 9.7.3 <<>> @ns1.domain.net any domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47636
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;domain.com.                    IN      ANY

;; ANSWER SECTION:
domain.com.             3600    IN      A       91.189.XXX.XX
domain.com.             3600    IN      MX      10 mail.domain.com.
domain.com.             3600    IN      NS      ns2.domain.net.
domain.com.             3600    IN      NS      ns1.domain.net.
domain.com.             3600    IN      SOA     ns1.domain.net me.domain.net. 2012032002 7200 540 604800 86400

;; ADDITIONAL SECTION:
mail.domain.com.        3600    IN      A       91.189.XXX.XX

;; Query time: 12 msec
;; SERVER: 81.167.96.220#53(81.167.96.220)
;; WHEN: Wed Mar 21 20:01:24 2012
;; MSG SIZE  rcvd: 176
Code:
dig @ns2.domain.net any domain.com

; <<>> DiG 9.7.3 <<>> @ns2.domain.net any domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47636
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;domain.com.                    IN      ANY

;; ANSWER SECTION:
domain.com.             3600    IN      A       91.189.XXX.XX
domain.com.             3600    IN      MX      10 mail.domain.com.
domain.com.             3600    IN      NS      ns2.domain.net.
domain.com.             3600    IN      NS      ns1.domain.net.
domain.com.             3600    IN      SOA     ns1.domain.net me.domain.net. 2012032002 7200 540 604800 86400

;; ADDITIONAL SECTION:
mail.domain.com.        3600    IN      A       91.189.XXX.XX

;; Query time: 12 msec
;; SERVER: 81.167.96.220#53(81.167.96.220)
;; WHEN: Wed Mar 21 20:01:24 2012
;; MSG SIZE  rcvd: 176
So if I'm correct. It should work. Where I bought my domain.com, I've set ns1.domain.net and ns2.domain.net as nameservers.

But if I try to make a new sub-domain with ISPconfig, it goes into the database on both servers. But nothing shows if I run:
Code:
dig @ns1.domain.net any sub.domain.com
; <<>> DiG 9.7.3 <<>> @ns1.domain any sub.domain.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 20882
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;sub.domain.com.                 IN      ANY

;; AUTHORITY SECTION:
domain.com.             3600    IN      SOA     ns1.domain.net. me.domain.net. 2012032002 7200 540 604800 86400

;; Query time: 1 msec
;; SERVER: 91.189.123.59#53(91.189.123.59)
;; WHEN: Wed Mar 21 20:08:52 2012
;; MSG SIZE  rcvd: 94
Reply With Quote
Sponsored Links
  #2  
Old 22nd March 2012, 09:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

There is most likely a configuration issue in the dns record that you created in ispconfig. Please take a look into the syslog file in /var/log/, you should fine some named / bind errors there which explains why bind cant load the file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd March 2012, 17:22
xzibiz xzibiz is offline
Junior Member
 
Join Date: Mar 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
grep -i named syslog
Mar 21 06:37:34 web2 named[807]: client 91.189.120.4#32388: query (cache) 'dynamic.vdc.vn.domain.net/A/IN' denied
Mar 21 09:54:35 web2 named[807]: client 91.189.120.4#45565: query (cache) '245.115.119.217.in-addr.arpa.domain.net/A/IN' denied
Mar 21 10:15:43 web2 named[807]: client 12.150.248.35#55340: query (cache) 'ns2.domain.net/AAAA/IN' denied
Mar 21 10:15:43 web2 named[807]: client 12.150.248.35#58280: query (cache) 'ns1.domain.net/AAAA/IN' denied
Mar 21 13:39:01 web2 named[807]: client 91.189.120.4#6426: query (cache) 'web2.bx-networks.net/MX/IN' denied
Mar 21 15:39:12 web2 named[807]: client 91.189.120.4#47172: query (cache) 'dssb00148.lunarbreeze.com.domain.net/A/IN' denied
Mar 21 16:51:01 web2 named[807]: client 81.167.36.3#6741: query (cache) 'isp.domain.net/A/IN' denied
Starting bind.
Code:
Mar 21 17:15:32 web2 named[18287]: starting BIND 9.7.3 -u bind
Mar 21 17:15:32 web2 named[18287]: built with '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' '--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--with-geoip=/usr' '--enable-ipv6' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=' 'CPPFLAGS='
Mar 21 17:15:32 web2 named[18287]: adjusted limit on open files from 1024 to 1048576
Mar 21 17:15:32 web2 named[18287]: found 1 CPU, using 1 worker thread
Mar 21 17:15:32 web2 named[18287]: using up to 4096 sockets
Mar 21 17:15:32 web2 named[18287]: loading configuration from '/etc/bind/named.conf'
Mar 21 17:15:32 web2 named[18287]: reading built-in trusted keys from file '/etc/bind/bind.keys'
Mar 21 17:15:32 web2 named[18287]: using default UDP/IPv4 port range: [1024, 65535]
Mar 21 17:15:32 web2 named[18287]: using default UDP/IPv6 port range: [1024, 65535]
Mar 21 17:15:32 web2 named[18287]: listening on IPv6 interfaces, port 53
Mar 21 17:15:32 web2 named[18287]: listening on IPv4 interface lo, 127.0.0.1#53
Mar 21 17:15:32 web2 named[18287]: listening on IPv4 interface eth0, 10.0.0.2#53
Mar 21 17:15:32 web2 named[18287]: generating session key for dynamic DNS
Mar 21 17:15:32 web2 named[18287]: set up managed keys zone for view _default, file 'managed-keys.bind'
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 254.169.IN-ADDR.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 100.51.198.IN-ADDR.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 113.0.203.IN-ADDR.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: D.F.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 8.E.F.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 9.E.F.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: A.E.F.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: B.E.F.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
Mar 21 17:15:32 web2 named[18287]: command channel listening on 127.0.0.1#953
Mar 21 17:15:32 web2 named[18287]: command channel listening on ::1#953
Mar 21 17:15:32 web2 named[18287]: zone 0.in-addr.arpa/IN: loaded serial 1
Mar 21 17:15:32 web2 named[18287]: zone 127.in-addr.arpa/IN: loaded serial 1
Mar 21 17:15:32 web2 named[18287]: zone 255.in-addr.arpa/IN: loaded serial 1
Mar 21 17:15:32 web2 named[18287]: zone domain.com/IN: loaded serial 2012032002
Mar 21 17:15:32 web2 named[18287]: zone localhost/IN: loaded serial 2
Mar 21 17:15:32 web2 named[18287]: managed-keys-zone ./IN: loading from master file managed-keys.bind failed: file not found
Mar 21 17:15:32 web2 named[18287]: managed-keys-zone ./IN: loaded serial 0
Mar 21 17:15:32 web2 named[18287]: running
Mar 21 17:15:32 web2 named[18287]: zone domain.com/IN: sending notifies (serial 2012032002)
Mar 21 20:29:01 web2 named[18287]: received control channel command 'reload'
Mar 21 20:29:01 web2 named[18287]: loading configuration from '/etc/bind/named.conf'
Mar 21 20:29:01 web2 named[18287]: /etc/bind/named.conf.local:3: undefined ACL 'ns2.domain.net'
Mar 21 20:29:01 web2 named[18287]: reloading configuration failed: failure
I get many like this., not sure what they mean...
Code:
Mar 22 08:00:04 web2 named[18287]: success resolving 'security.debian.org/A' (in 'security.debian.org'?) after reducing the advertised EDNS UDP packet size to 512 octets
Mar 22 10:36:52 web2 named[18287]: success resolving 'ns3.nic.fr/AAAA' (in 'nic.fr'?) after reducing the advertised EDNS UDP packet size to 512 octets
Mar 22 10:36:52 web2 named[18287]: success resolving 'sns-pb.isc.org/AAAA' (in 'isc.org'?) after reducing the advertised EDNS UDP packet size to 512 octets
Mar 22 10:36:52 web2 named[18287]: success resolving 'sns-pb.isc.org/A' (in 'isc.org'?) after reducing the advertised EDNS UDP packet size to 512 octets
Mar 22 10:36:53 web2 named[18287]: success resolving 'ns.jsinfo.net/AAAA' (in 'jsinfo.net'?) after reducing the advertised EDNS UDP packet size to 512 octets
Mar 22 10:36:53 web2 named[18287]: success resolving 'ns4.apnic.net/AAAA' (in 'apnic.net'?) after reducing the advertised EDNS UDP packet size to 512 octets
Mar 22 16:24:25 web2 named[18287]: success resolving 'r.arin.net/A' (in 'arin.net'?) after reducing the advertised EDNS UDP packet size to 512 octets

Last edited by xzibiz; 22nd March 2012 at 17:32.
Reply With Quote
  #4  
Old 17th September 2012, 22:03
spazio spazio is offline
Member
 
Join Date: Apr 2007
Posts: 38
Thanks: 1
Thanked 2 Times in 2 Posts
Default

I followed up the howto here:
http://www.ispconfig.org/news/tutori...ebian-squeeze/

Everything went ok.
Installation,
I can see the second server in the master ispconfig pannel.

But they don't synchronized. The /etc/bind/slave is empty

When the synchronization is supposed to happend? Is it on a cron job?
How can I force ispconfig to synchronize?

Thanks
S
Reply With Quote
  #5  
Old 17th September 2012, 23:16
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
Default

Hello,

I don't see in your queries any A records for your ns1 and ns2 (ADDITIONAL SECTION).

You need define both A records for your name servers.

Cheers
Reply With Quote
  #6  
Old 18th September 2012, 03:36
spazio spazio is offline
Member
 
Join Date: Apr 2007
Posts: 38
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Thanks pititis but I took an old tread so the beginning is not from me.
Regarding the A record. I do have both A record for ns1 and ns2.

Somebody know how ispconfig communicate between server ns1 and ns2?
What are the ports needed to be open?

S
Reply With Quote
  #7  
Old 18th September 2012, 08:57
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
 
Default

Ok, thanks.

Ports 53 tcp and udp must be open
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 13:04
problems after secondary install (mysql ispconfig user+dbispconfig) dinsdale Installation/Configuration 3 16th November 2010 21:06
Setting up a secondary DNS for ISPConfig 3 Blinkiz General 3 16th April 2010 00:02
Unable send receive emails vassilis3 Installation/Configuration 15 19th May 2007 15:34
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 10:45


All times are GMT +2. The time now is 12:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.