Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th March 2012, 19:54
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default Document Root directories permissions

Hi guys,

I have discovered that my apache service runs without using the suExec for each website created. At the moment I have a little problem with the right permissions of a directory. In my project there is a tmp directory that I use to save temporary files but I don't know which are the right permission for a secure writable folder.

Furthermore in the #httpd irc channel suggest me that I have to avoid to set the web directory with the 744 permission because is inadequate (thumbs).

I have seen that ISPConfig set the web document root with the 744, is it right?

Which are the default directory permissions?

thanks
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2012, 21:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
 
Default

Quote:
I have seen that ISPConfig set the web document root with the 744, is it right?
ISPConfig does not set 744 permissions, so you must have set that manually on your server. The web directory is set to 710 in ispconfig. There is no need to change any permissions manually, you should just enable suexec in the website settings. Using php without it is insecure and suexec ensures that php is run under the user of the website and not under the apache user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Update to ISPConfig 3.0.4 phpMyAdmin Problems midcarolina General 6 14th November 2011 15:54
Flash Player (version 10.0r22) did not load bobwdn HOWTO-Related Questions 10 11th September 2011 11:08
automatic webmail link admins Installation/Configuration 16 22nd June 2009 16:42
Setting up a new server - Suse 11.1 londonman Server Operation 34 10th April 2009 13:16
Postfix email server problems Access denied 554 554 5.7.1 state 14 AceRimmer Server Operation 4 19th June 2008 14:36


All times are GMT +2. The time now is 01:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.