Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th March 2012, 16:23
shakethefloor shakethefloor is offline
Junior Member
 
Join Date: Mar 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default phpMyAdmin not working

I have finally got everything set up on my vps, apart from phpmyadmin!

its a debian lenny with bind and dovecot

At first I just couldn't load the /phpmyadmin URL, either on the IP or on my domain, So I googled the problem, tried a reinstall and made a symlink to /var/www/phpmyadmin from /etc/phpmyadmin but when i browse to domain.co.uk/phpmyadmin (or /etc/phpmyadmin for that matter) I get these files:
Code:
apache.conf            config.header.inc.php  htpasswd.setup  phpmyadmin
config.footer.inc.php  config.inc.php         lighttpd.conf
But no index.php or anything. I took a look in the apache.conf and config.inc.php files but I had no idea if anything needed changing or why it wasn't working.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2012, 16:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Please remove the symlink that you made.

Then run:

dpkg-reconfigure phpmyadmin

and select that apt shall configure phpmyadmin for apache (items get selected with the space bar on the keyboard). Afterwards restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
shakethefloor (9th March 2012)
  #3  
Old 9th March 2012, 22:17
shakethefloor shakethefloor is offline
Junior Member
 
Join Date: Mar 2012
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
 
Smile

Solved it again, thank you so much.

I realise where I went wrong. In the initial set up I pressed Enter instead of Space to select which one i wanted, so it was a blank selection.

Thanks again.
Reply With Quote
Reply

Bookmarks

Tags
debian, ispconfig3, lenny, mysql, phpmyadmin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin not working belleview Installation/Configuration 8 31st January 2012 19:46
phpmyadmin not working correctly? Check your suhosin settings... talkingnews Tips/Tricks/Mods 0 5th December 2011 00:12
phpmyadmin stopped working kinsol Installation/Configuration 7 15th November 2011 20:24
PHPMyadmin quit working overnight crypted General 2 30th November 2010 01:25
php and phpmyadmin not working MBAngel Installation/Configuration 8 10th October 2010 05:51


All times are GMT +2. The time now is 21:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.