Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 18th February 2012, 16:33
anset anset is offline
Junior Member
 
Join Date: Jan 2012
Posts: 11
Thanks: 1
Thanked 3 Times in 2 Posts
Thumbs up One master, two slaves running CentOS 6.2 update successfully.

Hi,

This was the first time I used the update process.

As someone already posted, the update process hangs after starting mailman. If at that point (in another shell) you stop the mailman service with "service mailman stop", the update process resumes after a few seconds. A couple more services restart and the update is finished. (At which point you of course need to restart the mailman service.)

A more annoying problem I had was with my SSL certificates:
- I have some "real" certs for the ispconfig site, but the ispconfig.vhost file was overwritten. I needed to put the original file (content) back.

- All three of the installes run a postfix mail server with "real" SSL certs. Sine the main.conf file was overwritten, those needed to be put back manually too.

Not sure how you would be able to fix these issues since these certs cannot be entered into the ispconfig interface (please correct me if I am wrong). Even for the ispconfig vhost, putting the certs in the default location does not work since I need to add a certificate chain bundle file and the default vhost file only hase the cer and key files entered.

But all in all these issues are minor and easy to fix (using the automatic etc backup) so I am totally happy with the product and the update process.

Thank you for the awesome product.

Anset

PS. For those who do not have the manual yet; it's totally worth the small purchase price!
Reply With Quote
The Following 2 Users Say Thank You to anset For This Useful Post:
falko (19th February 2012), till (20th February 2012)
Sponsored Links
  #22  
Old 19th February 2012, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by anset View Post
A more annoying problem I had was with my SSL certificates:
- I have some "real" certs for the ispconfig site, but the ispconfig.vhost file was overwritten. I needed to put the original file (content) back.

- All three of the installes run a postfix mail server with "real" SSL certs. Sine the main.conf file was overwritten, those needed to be put back manually too.

Not sure how you would be able to fix these issues since these certs cannot be entered into the ispconfig interface (please correct me if I am wrong). Even for the ispconfig vhost, putting the certs in the default location does not work since I need to add a certificate chain bundle file and the default vhost file only hase the cer and key files entered.
That is right. A few of these issues are outlined here: http://www.howtoforge.com/securing-y...-from-startssl
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #23  
Old 25th February 2012, 13:10
fredol fredol is offline
Junior Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hello

I have exactly the same behaviour since upgrading to 3.0.4.3, quite annoying.

But the real problem is that system state and server state stay green even when there are system update available.

Did you had time to check this problem ?

Thanks in advance

Regards

Fredol
Reply With Quote
  #24  
Old 26th February 2012, 12:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by fredol View Post
But the real problem is that system state and server state stay green even when there are system update available.

Did you had time to check this problem ?
We're working on this already.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 27th February 2012, 10:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,779
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

Quote:
Originally Posted by fredol View Post
Hello

I have exactly the same behaviour since upgrading to 3.0.4.3, quite annoying.

But the real problem is that system state and server state stay green even when there are system update available.

Did you had time to check this problem ?

Thanks in advance

Regards

Fredol
This has already been fixed in SVN a fewdays ago.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #26  
Old 28th February 2012, 10:49
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 136
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Default

Quote:
Originally Posted by anset View Post
Hi,

A more annoying problem I had was with my SSL certificates:
- I have some "real" certs for the ispconfig site, but the ispconfig.vhost file was overwritten. I needed to put the original file (content) back.
generally i do not allow update to reconfigure services to avoid these issues
i have many customization on postfix conf files

Code:
Reconfigure Services? (yes,no) [yes]: no
i should check what i miss, but i am too lazy to do it, i will do, one day
Reply With Quote
  #27  
Old 6th March 2012, 15:11
lollollollol lollollollol is offline
Member
 
Join Date: Nov 2011
Location: Madagascar
Posts: 44
Thanks: 7
Thanked 6 Times in 5 Posts
 
Default

Quote:
Originally Posted by Hans View Post
Dear Falko & Till,
I just upgraded my Debian Squeeze homeserver.
The upgrade from 3.0.4.2 to 3.0.4.3 went fine and all looks great!
Thanks for this new release.
Hello,
nothing else to say.
Thank you!
Reply With Quote
The Following User Says Thank You to lollollollol For This Useful Post:
falko (7th March 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All files gone after changing quota to 0 spynode General 17 19th January 2012 15:41
ISPConfig 3.0.3 released till General 52 2nd December 2010 18:24
ISPConfig 3.0.1 released till General 36 29th March 2009 15:30
ISPConfig 3.0.0.6 Beta released till General 38 21st September 2008 20:15
ISPConfig 2.3.3-dev released till General 10 12th March 2008 22:08


All times are GMT +2. The time now is 15:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.