Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th February 2012, 18:58
matpen matpen is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dashboard with own RSS Feed fails

I am trying to configure the ISPconfig3 dashboard with a custom RSS feed based on b2evolution. Apparently something is wrong, because I see an empty dashboard.

These are the steps I have taken:
- log in into ISPconfig as admin
- under System > Interface Config > Misc set the link given by b2evolution (I tryed both RSS and atom types)
- exit and login again

The dashboard is completely empty. Is this due to an incompatibility with b2evo or am I missing something?

Thank you in advance!
matpen

PS I can provide the link to the RSS feed if needed
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2012, 09:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

ISPConfig supports atom feeds, the default feed is a feed provided by the wordpress blog on ispconfig.org, so nothing special at all. So most likely your feed is not compatible then.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st March 2012, 16:10
matpen matpen is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Till, thank you for your reply.

I looked a bit more into this, and it turns out it is an issue with the simplepie feed client. I am using ISPconfig3 3.0.4.3 (the latest version at the time of this writing), which in turns uses simplepie 1.2.1-dev.

The problem is that b2evo-provided feeds use the URL format http://myblog.com/?tempskin=_atom, which is not parsed correctly by this version of simplepie: the "=" sign gets encoded and the feed is not found.

However, the fix is very easy. Simply edit the file "simplepie.inc.php" and change line 12154 from
PHP Code:
$this->query $this->replace_invalid_with_pct_encoding($query'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789-._~!$\'()*+,;:@/?'); 
to
PHP Code:
$this->query $this->replace_invalid_with_pct_encoding($query'ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789-._~!$\'()*+,;:@/?&='); 
(ie. add the "&=" at the end of the line)

Prior to ISPconfig3 installation, this file is found in ispconfig3_install/interface/lib/classes/simplepie.inc.php. After installation it is in /usr/local/ispconfig/interface/lib/classes/simplepie.inc.php.

I would like to point out that simplepie 1.2.1 stable seems to fix this bug. I strongly suggest this as the version in future releases of ISPconfig. Till, do you want me to file a reminder somewhere?

Anyway, I hope the above helps.
Regards.
matpen
Reply With Quote
  #4  
Old 1st March 2012, 16:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
 
Default

Thanks for the patch. I've added it to the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard with own RSS Feed admins Installation/Configuration 1 7th October 2010 15:28
Facebook RSS feed app invite page deprecated godrox HOWTO-Related Questions 16 29th January 2010 07:37
Feed updating problem at Facebook RSS Reader Application rookieguy Programming/Scripts 1 21st December 2008 14:34
Facebook RSS odd symbol melat0nin HOWTO-Related Questions 7 6th June 2008 17:13
Howtos RSS feed? edge Suggest HOWTO 8 14th February 2007 20:58


All times are GMT +2. The time now is 03:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.