Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th February 2012, 14:49
tested0002 tested0002 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Wordpress Error 500 on ISPConfig3.0.4.3 NGINX

Hi to all the members,Moderators and Admins of ISPConfig.

First of all I would like to thank you for the great software you have here. I came here because I search the forums but I couldn't find what really the great solution to my problem.

I have successfully installed ISPConfig 3 to my Centos 6.2 VPS with 1GB of RAM.
I use NGINX as my default web server. And the problem goes here. I upload wordpress files to my server and i have

1. Chown all the files to current user and group.
2. Removed the .htaccess file on the root directory.
3. Chmod files from 644 to 755 (tried also 777 but no luck, switch back to original permissions)

But I got ERROR 500 - Internal Server Error!... And I can't continue with the installation. By the way I put the wordpress files to root directory of my domain.

My current vhost.conf
Code:
server {
        listen *:80;

        server_name www.xxxxxxx.info ;
        root   /var/www/www.xxxxxxx.info/web;

        index index.html index.htm index.php index.cgi index.pl index.xhtml;

        error_page 400 /error/400.html;
        error_page 401 /error/401.html;
        error_page 403 /error/403.html;
        error_page 404 /error/404.html;
        error_page 405 /error/405.html;
        error_page 500 /error/500.html;
        error_page 502 /error/502.html;
        error_page 503 /error/503.html;

        error_log /var/log/ispconfig/httpd/www.xxxxxxx.info/error.log;
        access_log /var/log/ispconfig/httpd/www.xxxxxxx.info/access.log combined;

        ## Disable .htaccess and other hidden files
        location ~ /\. {
            deny all;
            access_log off;
            log_not_found off;
        }

        location = /favicon.ico {
            log_not_found off;
            access_log off;
        }

        location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
        }

        location /stats {
            index index.html index.php;
            auth_basic "Members Only";
            auth_basic_user_file /var/www/clients/client3/web6/.htpasswd_stats;
        }

        location /awstats-icon {
            alias /usr/share/awstats/icon;
        }

        location ~ \.php$ {
           try_files $uri =404;
            include /etc/nginx/fastcgi_params;
            fastcgi_pass unix:/var/lib/php5-fpm/web6.sock;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_script_name;
            fastcgi_intercept_errors on;
        }

}
I use this configuration on Joomla and It works without any problem. No error 500.

Please anyone here having this kind of problem and if you already fixed this please share it with us. Please if you need anymore info about my configuration please ask and I will post it again here.

Thank you
Reply With Quote
Sponsored Links
  #2  
Old 29th February 2012, 15:50
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Did you check de error.log of your site? which php mode are you using? mod-php, fast-cgi (remember to enable suexec), other?
Reply With Quote
  #3  
Old 29th February 2012, 16:00
tested0002 tested0002 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by erosbk View Post
Did you check de error.log of your site? which php mode are you using? mod-php, fast-cgi (remember to enable suexec), other?
I have checked the logs and I got only this

Code:
2012/02/29 16:58:18 [error] 3999#0: *4 directory index of "/var/www/www.xxxxxxx.info/web/" is forbidden, client: 59.xx.xxx.xx, server: www.xxxxxxx.info, request: "GET / HTTP/1.1", host: "test.whitemovies.info"
And about the PHP handler I use php-fpm. I couldn't find this suexec on my ISPConfig panel. Do I need to install this?
Reply With Quote
  #4  
Old 29th February 2012, 16:03
tested0002 tested0002 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by erosbk View Post
Did you check de error.log of your site? which php mode are you using? mod-php, fast-cgi (remember to enable suexec), other?
My log
Code:
2012/02/29 16:58:18 [error] 3999#0: *4 directory index of "/var/www/www.xxxxxxx.info/web/" is forbidden, client: 59.xxx.xxx.xxx, server: www.xxxxxxx.info, request: "GET / HTTP/1.1", host: "www.xxxxxxx.info"
Additional Post: (Can't view my latest post.) I use fast-cgi together with PHP-FPM.

Last edited by tested0002; 29th February 2012 at 16:06.
Reply With Quote
  #5  
Old 29th February 2012, 16:29
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

is suexec enabled (enable it and test if not)? do you have an index in the home directory of your site or you put wordpress inside a folder?
Reply With Quote
  #6  
Old 29th February 2012, 16:43
tested0002 tested0002 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by erosbk View Post
is suexec enabled (enable it and test if not)? do you have an index in the home directory of your site or you put wordpress inside a folder?
No I don't have suexec. I use NGINX and I don't think it will work (Please guide me how to enable or install suexec on NGINX) I can't find any option of "suexec" on the CP its just "Fast-CGI" on the list.

Yes I have all the files of wordpress on my home directory.

I just followed the tutorials here http://www.howtoforge.com/perfect-se...ispconfig-3-p1 but seems I have trouble or maybe there might be missing installation about the suexec you are referring to.
Reply With Quote
  #7  
Old 29th February 2012, 16:46
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Sorry, I was thinking in apache, not in nginx! nginx doesn't need suexec... maybe someone with knowledge of nginx could help you better than me
Reply With Quote
  #8  
Old 21st March 2012, 15:32
hanti hanti is offline
Junior Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 6 Times in 1 Post
Default

u need to comment out or delete
fastcgi_intercept_errors on;
Reply With Quote
  #9  
Old 29th April 2012, 15:17
fco fco is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default ERROR 500 - Internal Server Error!

I have the same problem:
I'm using ISPCONFIG 3.0.4.4
With default configuration wordpress give Error 500.
I've tried various patch in site->options->nginx Directives textarea but I have not found a vali solution.
If I deactivate the site ttw and create a custom vhost file in /etc/nginx/sites-available and activate it, wordpress works

What is the correct code to past in site->options->nginx Directives for Wordpress ?

Thanks
Reply With Quote
  #10  
Old 29th April 2012, 15:48
hanti hanti is offline
Junior Member
 
Join Date: Mar 2012
Posts: 9
Thanks: 0
Thanked 6 Times in 1 Post
 
Default

u can do nothing becouse there is already in vhost file
fastcgi_intercept_errors on;
and this need to be deleted
u can find and delete fastcgi_intercept_errors on; in file /usr/local/ispconfig/server/conf/nginx_vhost.conf.master
after that every new site u will create in panel will work with wordpress
Reply With Quote
The Following 6 Users Say Thank You to hanti For This Useful Post:
profm2 (3rd May 2012), riverman (12th November 2012), smith23 (15th November 2012), SudoCat (2nd June 2013), swehes (24th September 2012), untor (9th November 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13 MrCompTech Tips/Tricks/Mods 7 7th January 2014 01:07
nginx Segmentation fault Error,The Perfect Server - CentOS 6 With nginx [ISPConfig 3] alihan1988 HOWTO-Related Questions 0 2nd February 2012 17:07
Nginx doesn´t restart after installation of ISPConfig 3 cyprus Installation/Configuration 2 6th November 2011 18:48
A Working Nginx Catchall with ISPConfig 3. renders Tips/Tricks/Mods 4 15th April 2011 21:53
ISPConfig 3.x - First Steps (Creating Web Sites, Email Addresses, Etc.) sighkick Suggest HOWTO 18 7th October 2010 00:12


All times are GMT +2. The time now is 07:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.