Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th February 2012, 23:19
jackl jackl is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to change ISPConfig 3 Default VHost Port

Hi There!

I'm installing Varnish Cache and varnish needs apache vhost to listen to the port is was assigned to, in my case port 8000. I copied ispconfig vhost.conf.master to conf-custom but the port has this:
{tmpl_var name='port'}
I assumed that ISPConfig3 GUI has this setting under webserver settings but there is no field for VHost Port, I only see Apps VHost Port.

Is there any other part of ISPConfig3 GUI that hides apache vhost port? If no, is it safe to just change:
{tmpl_var name='port'}
to
8000
Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 25th February 2012, 12:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by jackl View Post
If no, is it safe to just change:
{tmpl_var name='port'}
to
8000
Thanks!
That should work.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th September 2013, 11:44
scarleo scarleo is offline
Junior Member
 
Join Date: Sep 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Doesn't work if you have SSL enabled for the site in question as this will also modify the SSL VirtualHost port from 443 to 8000. I really think we should have a setting for this in ispconfig3 interface. If there already is one I would be very happy if someone could point me to where it is.

EDIT: This works if you have SSL for the site, just in case someone else is looking for a solution. Not really sure abt the tmpl syntax so it might be a bit redundant, but it works :

<tmpl_loop name="vhosts">
<tmpl_if name='port' op='==' value='80'>
<VirtualHost {tmpl_var name='ip_address'}:8000>
</tmpl_else>
<tmpl_if name='port' op='==' value='443'>
<VirtualHost {tmpl_var name='ip_address'}:443>
</tmpl_if>
</tmpl_if>

Last edited by scarleo; 15th September 2013 at 11:59. Reason: solution/workaround
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 20:02
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 11:56
how to change the default port 81 ? Jugernaut Installation/Configuration 12 10th February 2010 15:09
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39
how to change default vhost Ovidiu General 14 7th February 2009 12:50


All times are GMT +2. The time now is 21:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.