Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th February 2012, 15:56
PlanetMaster PlanetMaster is offline
Junior Member
 
Join Date: Feb 2012
Location: New York
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Error after update to 3.0.4.3: BUG?

After I upgraded to the latest stable release my server stopped updating its logs and services. I removed the .ispconfig_lock file and commented out the cron job for server.sh and ran the following in debug mode:

Code:
/usr/local/ispconfig/server/server.sh
Heres the error having to do with backups:
Code:
PHP Fatal error:  Call to undefined method plugins::registerAction() in /usr/local/ispconfig/server/plugins-available/backup_plugin.inc.php on line 54
Oddly enough this file isnt included in the latest releases plugins list.
http://fossies.org/dox/ISPConfig-3.0...hp_source.html

Did you guys miss this and it hasnt been updated for the new release? I usually do my own error fixing but not knowing the way this file is being used off hand will make it a bit tougher. Plus could be reported as a bug possibly?

Just for reference here is the line(s) in question:
PHP Code:
                //* Register for actions
                
$app->plugins->registerAction('backup_download',$this->plugin_name,'backup_action');
                
$app->plugins->registerAction('backup_restore',$this->plugin_name,'backup_action'); 
Thanks for any assistance...

Last edited by PlanetMaster; 15th February 2012 at 15:58.
Reply With Quote
Sponsored Links
  #2  
Old 15th February 2012, 17:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Thats no bug. The code you posted is not in ispconfig 3.0.4.3 and was never a part of the 3.0.4.x release series, the file /usr/local/ispconfig/server/plugins-available/backup_plugin.inc.php is from svn trunk (ISPConfig 3.0.5).

Seems as if you copied code from trunk on your server, maybe as you tried to fix something? Or you updated your server to svn trunk and now downgraded to stable. Delete the file /usr/local/ispconfig/server/plugins-available/backup_plugin.inc.php as its not required for 3.0.4.3 and can not work in 3.0.4.3 as it is for and reguires svn trunk version.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 15th February 2012 at 17:04.
Reply With Quote
  #3  
Old 15th February 2012, 17:25
PlanetMaster PlanetMaster is offline
Junior Member
 
Join Date: Feb 2012
Location: New York
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Yeah just figured that out and made the corrections. Thanks.

I was adding my SSL email ports in the monitor services and made an error in one of my edits. Got it all working now.
Attached Images
 

Last edited by PlanetMaster; 15th February 2012 at 19:47.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Centos is terribly slow Galled Server Operation 9 7th December 2010 15:31
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19


All times are GMT +2. The time now is 12:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.