#1  
Old 13th February 2012, 18:59
pyx69 pyx69 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Question Using-php5-fpm-with-apache2

Hello

I'm using debian squeeze instead of ubuntu and packages from dotdeb.

I can't get phpinfo page working. I get a blank page.

on apache error log I have:

[Mon Feb 13 18:23:04 2012] [notice] caught SIGTERM, shutting down
[Mon Feb 13 18:23:04 2012] [alert] (4)Interrupted system call: FastCGI: read() from pipe failed (0)
[Mon Feb 13 18:23:04 2012] [alert] (4)Interrupted system call: FastCGI: the PM is shutting down, Apache seems to have disappeared - bye

any suggestions?
Thanks
P.
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2012, 14:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you post your vhost configuration and the output of
Code:
netstat -tapn
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 14th February 2012, 14:27
pyx69 pyx69 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Thumbs up Solved

Hello,

I solved it... it was a stupid thing , the php.ini for FPM did not have short_open_tag on and my script did'nt have <?php long tag.

Sorry for the disturb.

Do you think it is better to add the following directive?

<Location "/usr/lib/cgi-bin/php5-fcgi">
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS
Options ExecCGI FollowSymLinks
SetHandler fastcgi-script
</Location>

Thank you.
P.
Reply With Quote
  #4  
Old 22nd February 2012, 15:34
pyx69 pyx69 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default Another problem with PHP scripts without extension

Hello,

I can't execute PHP file without extension.

Putting SetHandler fastcgi-script in .htaccess makes Apache hang until timeout and i get in the log:
[warn] FastCGI: (dynamic) server "/html/testscript" has failed to remain running for 30 seconds given 3 attempts, its restart interval has been backed off to 600 seconds

Putting SetHandler php5-fcgi in .htaccess results in error Access denied with 403 error in access log

I tried to add all of the following (one by one) in .htaccess (now I commented them all)
<Files testscript>
#ForceType application/x-httpd-php
#Action php5-fcgi /php5-fcgi
#SetHandler fastcgi-script
#SetHandler php5-fcgi
</Files>

My apache config is :

ScriptAlias /cgi-bin/ "/usr/lib/cgi-bin/"
AddHandler php5-fcgi .php
Action php5-fcgi /php5-fcgi
Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi
FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -socket /tmp/php5-fpm.sock -pass-header Authorization

<Location "/usr/lib/cgi-bin/php5-fcgi">
Order Deny,Allow
Deny from All
Allow from env=REDIRECT_STATUS
Options ExecCGI FollowSymLinks
SetHandler fastcgi-script
</Location>

I hope in someone's help.

Ciao
P

Last edited by pyx69; 22nd February 2012 at 15:56.
Reply With Quote
  #5  
Old 22nd February 2012, 17:00
pyx69 pyx69 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
 
Default Solved again

it was the new php-fpm security config option : security.limit_extensions

you must add the name of the file without extension to be parsed to it.

Ciao
P.
Reply With Quote
The Following User Says Thank You to pyx69 For This Useful Post:
falko (24th February 2012)
Reply

Bookmarks

Tags
apache, fastcgi, php, php5-fpm

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.1.4 causes Apache to have too many open files gkovacs Installation/Configuration 29 27th February 2013 08:59
Apache2 high load lano Server Operation 3 24th December 2011 17:29
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Upgrade to php 5.2 in suse 10.1 gimhan90 Installation/Configuration 3 1st January 2009 20:32
eaccelerator installation - can't find php5-config tom Programming/Scripts 9 15th May 2006 15:36


All times are GMT +2. The time now is 02:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.