Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th January 2012, 18:09
platan platan is offline
Junior Member
 
Join Date: Oct 2008
Posts: 9
Thanks: 0
Thanked 4 Times in 2 Posts
Send a message via Skype™ to platan
Default Bug? Custom mail login (optional) not optional?

Ispconfig 3.0.4.2 - login as admin

---------------------

System -> Interface config -> Mail ->
Allow custom login name: [x] <- check it

---------------------

Email -> Email mailbox -> Add new Mailbox ->
Email: [i ] @ [example.tld ] <- fill it
Login (optional): [ ] <- leave blank (after all, is optional)
Password: [******* ]
Save <- go

-> ERROR
-> 1. Valid characters are A-Z, a-z, 0-9, ., _ and -.

- What is that unspecified error? Suddenly, the error is empty optional login field.

------

I trying unvisible move customer's virtuals from Ispconfig2 to Ispconfig3. This is a great idea! A dream come true.
1. For new email -> login as full email adress (automagick with empty optional custom login).
2. For old email logins from Ispconfig2 system -> custom web555_somebody with password from /etc/shadow file, inserted direct into database (it works!).

BUT somethin goes wrong.
There is no automatic full e-mail login when custom login (optional) is empty.
OK, I anderstand. There is no dual login for one e-mail account. But why optional login is not optional? Why optional field must be filled?

Please help

Best regards

Tomasz Oleksiewicz
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2012, 18:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,561
Thanks: 791
Thanked 4,978 Times in 3,899 Posts
Default

If you enable the email login field in interface config, then you have to use it for all email accounts on your server and fill in the username that shall be used as email login. So there is no bug here, its optional to enable the login field, but when you have it enabled, then its mandatory that you fill in the username.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th January 2012, 11:04
platan platan is offline
Junior Member
 
Join Date: Oct 2008
Posts: 9
Thanks: 0
Thanked 4 Times in 2 Posts
Send a message via Skype™ to platan
Default

Thank you for your answer.
That's exactly what I understood.
In addition, I propose to change the label "Login (optional):" to "Login (mandatory) *:" (with asterisk) in all translations.
Or not! Perhaps in the next version of the system, the field will be truly optional.
Ispconfig, this is great work! Congratulations and best regards.
Reply With Quote
  #4  
Old 30th January 2012, 22:29
platan platan is offline
Junior Member
 
Join Date: Oct 2008
Posts: 9
Thanks: 0
Thanked 4 Times in 2 Posts
Send a message via Skype™ to platan
Default

Ouch!
Interface - is not problem.
Problem is: postfix does not work with custom login.
Configuration described above.

Modify /var/vmail/.mailfilter, add

LINE="0:$0 1:$1 2:$2 3:$3 4:$4 5:$5 6:$6 7:$7"
`echo $LINE >> /var/vmail/.maildrop.pipe.log`

to check if maildrop is started or not.


Example
Email: bar@oleksiewicz.pl
Login: web30_bar

Postfix step 1 - OK:
Jan 30 22:03:58 s5d1 postfix/smtp[1574]: 9BACDC0E13: to=<bar@oleksiewicz.pl>, relay=127.0.0.1[127.0.0.1]:10024, delay=1, delays=0.11/0.02/0.01/0.88, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=00571-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 85E48C0E24)

Amavis... - step 2 - OK...

Postfix step 3 - BAD:
Jan 30 22:03:58 s5d1 postfix/pipe[1581]: 85E48C0E24: to=<bar@oleksiewicz.pl>, relay=maildrop, delay=0.08, delays=0.01/0.03/0/0.05, dsn=5.1.1, status=bounced (user unknown. Command output: Invalid user specified. )

This look like maildrop probem, but maildrop is not started. Postfix has a problem with the preparation of maildrop command.

Example 2:
Email: tom@oleksiewicz.pl
Login: tom@oleksiewicz.pl
All fine!

HELP! HELP! HELP!
Reply With Quote
  #5  
Old 31st January 2012, 08:43
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,561
Thanks: 791
Thanked 4,978 Times in 3,899 Posts
Default

I guess the problem is maildrop / courier and not postfix. Maildrop is bouncind as it does not find the user and the user is checked before it executes the mailfilter script. Please check the courier sql config files if courier authenticates against the login column and not the email column.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 31st January 2012, 13:11
platan platan is offline
Junior Member
 
Join Date: Oct 2008
Posts: 9
Thanks: 0
Thanked 4 Times in 2 Posts
Send a message via Skype™ to platan
Default

This is clean configuration The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]
Reply With Quote
  #7  
Old 12th February 2012, 00:50
platan platan is offline
Junior Member
 
Join Date: Oct 2008
Posts: 9
Thanks: 0
Thanked 4 Times in 2 Posts
Send a message via Skype™ to platan
 
Default

Quote:
Originally Posted by till View Post
I guess the problem is maildrop / courier and not postfix. Maildrop is bouncind as it does not find the user and the user is checked before it executes the mailfilter script. Please check the courier sql config files if courier authenticates against the login column and not the email column.
Well, I did so:
In /etc/postfix/master.cf change
Code:
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
into
Code:
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
and WORKS (maildrop quota ok)!!

BUT!

Does that make sense?
Is it safe?
Is it consistent with the idea Ispconfig3?
Is it always work?

Help me please

Last edited by platan; 13th February 2012 at 13:05.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail-Problema jz_ HOWTO-Related Questions 9 14th September 2011 13:31
postfix problem jagsler Server Operation 41 7th July 2011 14:19
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 16:27
Need help get mail to work (can't recieve and apperently can't send) omega13a Installation/Configuration 19 20th August 2009 21:06


All times are GMT +2. The time now is 10:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.