Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th February 2012, 20:03
coyote39 coyote39 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Issues with creating a website

I'm sure this subject has been beaten to death, and I have tried my very best to follow the ISPConfig manual, but I can't seem to figure out how to do what I am trying to do with my server.

I am trying to create websites on my server. The domain names are registered through no-ip.com because I have to use redirects to port 8080 (my ISP blocks port 80), and the ip address is dynamic. The domain names (we'll call them website1.us and website2.com are registered and pointing to my external ip (we'll call that 11.22.33.44 ) and forwarded to port 8080 (which is not blocked by my ISP). My router is port forwarding all traffic coming in on 8080 to 80 on the server. This is confirmed as I can hit the server externally using the domain names listed on no-ip.com. However, I hit the generic index.html which is located in the /var/www/ directory on the server.

When I try to set up the website in ISPConfig3, I am following the manual and tutorial located here: http://docs.ispconfig.org/creating-web-sites/

When I set everything up (whether under a dummy client or not), and try to connect externally, it is still sending me to the default index.html located under the /var/www/ folder. Can someone please help a total noob and tell me what's going on and what I need to do to fix it?

Thank you in advance for your time and patience in this matter.
Reply With Quote
Sponsored Links
  #2  
Old 6th February 2012, 20:34
mrbronz mrbronz is offline
Junior Member
 
Join Date: Feb 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had jus the same problem today...

Have a look at this see if it help..

http://www.howtoforge.com/forums/sho...066#post273066
Reply With Quote
  #3  
Old 6th February 2012, 23:53
coyote39 coyote39 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the response. It seems that we are quite similar setup-wise, but I must be missing something here.

I tried to follow that post as well, but still wasn't having any luck.

When you set yours up, did you set up any DNS zones, or did you just add the website since no-ip.com is your dns service? I think the problem for me lies somewhere between no-ip and the dns zones on ISPConfig. Just so maybe you can compare, on no-ip.com i have the domains set up like this:

Domain#1: website1.us

Hosts:

website1.us IP: 11.22.33.44:8080
ftp.website1.us 11.22.33.44:8080
mail.website1.us 11.22.33.44:8080
www.website1.us 11.22.33.44:8080

Domain#2: website2.com

Hosts:

website2.com IP: 11.22.33.44:8080
ftp.website2.com 11.22.33.44:8080
mail.website2.com 11.22.33.44:8080
www.website2.com 11.22.33.44:8080

Each host is set up as a Port 80 redirect (I have to do this as my ISP blocks port 80).

I am trying to set up the server, so that each domain name points to its own website, which I am trying to create (unsuccessfully) in ISPConfig.

Honestly, I don't know exactly where the problem lies, and admittedly - I'm pretty much a noob at this. If someone can help me out, I would greatly appreciate it. Thanks in advance for your time and effort in teaching me.
Reply With Quote
  #4  
Old 7th February 2012, 08:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,380
Thanks: 833
Thanked 5,479 Times in 4,313 Posts
Default

Ensure that you selcted the internal and not external IP in the website settings for the site sin ispconfig. If the Ip does not show up there yet, add it under system server IP.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 7th February 2012, 11:09
mrbronz mrbronz is offline
Junior Member
 
Join Date: Feb 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by coyote39 View Post
did you set up any DNS zones.
No I did not set up a DNS

For the site to work with no-ip all you need to do is create a host in your no-ip account. and USE THE IP ADDRESS of the server that the site sits on. when creating the site
The only 2 bits of info you really need are the Domain and the IP address

Name:  ispconfig3.jpg
Views: 165
Size:  37.1 KB

If the IP address is set to '*' it wont work you must add the IP address as stated a few posts up

Let me know if this helps
Reply With Quote
  #6  
Old 8th February 2012, 01:57
coyote39 coyote39 is offline
Junior Member
 
Join Date: Feb 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I knew my issue was with the DNS zones. Once I deleted the zones and just used the local address for the websites as posted above, I could hit the site. Thanks to all who took the time to help and answer.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem creating website in ispconfig 3.0.3.2 Knot Installation/Configuration 1 3rd February 2011 21:34
creating www2 website crypted General 6 11th September 2010 18:22
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 14:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.