Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st February 2012, 11:58
Skyflash Skyflash is offline
Member
 
Join Date: Sep 2011
Posts: 56
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Skyflash
Default

I think i've found it:

Code:
root@server01:/var/www/skyflash.it/web# vi /var/www/php-fcgi-scripts/web2/.php-fcgi-starter 

#!/bin/sh
PHPRC="/etc/php5/cgi/"
export PHPRC
PHP_DOCUMENT_ROOT="/var/www/clients/client1/web2"
export PHP_DOCUMENT_ROOT
# The variable PHP_FCGI_CHILDREN is onyl useful for lighty or nginx as apache 
# mod_fcgi will control the number of childs themself and never use the additional processes.
# PHP_FCGI_CHILDREN=1
# export PHP_FCGI_CHILDREN
PHP_FCGI_MAX_REQUESTS=1000
export PHP_FCGI_MAX_REQUESTS
exec /usr/bin/php-cgi \
 $1
Reply With Quote
Sponsored Links
  #12  
Old 1st February 2012, 15:36
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
Default

You don't use open_basedir restrictions??
Reply With Quote
  #13  
Old 1st February 2012, 15:56
Skyflash Skyflash is offline
Member
 
Join Date: Sep 2011
Posts: 56
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Skyflash
Default

Quote:
Originally Posted by pititis View Post
You don't use open_basedir restrictions??
In the site's configuration document there are:
Code:
/var/www/clients/client1/web2/web:/var/www/clients/client1/web2/tmp:/var/www/skyflash.it/web:/srv/www/skyflash.it/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin
Reply With Quote
  #14  
Old 1st February 2012, 16:13
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
Default

Yeah sure but see your /var/www/php-fcgi-scripts/web2/.php-fcgi-starter

..nothing.


I don't know if its ispcofig related issue but try to apply or change the website options tab.

...e poi ci racconti
Reply With Quote
  #15  
Old 1st February 2012, 16:18
Skyflash Skyflash is offline
Member
 
Join Date: Sep 2011
Posts: 56
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Skyflash
Default

Quote:
Originally Posted by pititis View Post
Yeah sure but see your /var/www/php-fcgi-scripts/web2/.php-fcgi-starter

..nothing.


I don't know if its ispcofig related issue but try to apply or change the website options tab.

...e poi ci racconti
Re-applied and nothing has been changed
Otherwise, other websites has the correct openbasedir instruction

... e non cambia, il fetecchione
Reply With Quote
  #16  
Old 1st February 2012, 16:23
Skyflash Skyflash is offline
Member
 
Join Date: Sep 2011
Posts: 56
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Skyflash
Default

I tried deleting the .php-fcgi-starter, then modify and re-apply the configuration in ISPConfig

ISPConfigr recreated the file, but its the same, without ANY openbasedir instruction

Heeeeelp!
Reply With Quote
  #17  
Old 1st February 2012, 16:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

1) Which ISPConfig version do you use?
2) Post the outout of:

ls /usr/local/ispconfig/server/conf-custom/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 1st February 2012, 16:32
Skyflash Skyflash is offline
Member
 
Join Date: Sep 2011
Posts: 56
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Skyflash
Default

Quote:
Originally Posted by till View Post
1) Which ISPConfig version do you use?
Latest, 3.0.4.2

Quote:
2) Post the outout of:
ls /usr/local/ispconfig/server/conf-custom/
Code:
root@server01:/var/www/php-fcgi-scripts/web2# ls /usr/local/ispconfig/server/conf-custom/
error  index  mail
Reply With Quote
  #19  
Old 6th February 2012, 14:21
Skyflash Skyflash is offline
Member
 
Join Date: Sep 2011
Posts: 56
Thanks: 4
Thanked 2 Times in 2 Posts
Send a message via Skype™ to Skyflash
Default

I think i've a trouble in the ISPConfig configuration.

I've just created a new site. Created the client, the site, db and ftp access.
This is the configuration document:


Now i'm checking site's .php-fgci-starter file, and it has no openbasedir directive:

Code:
#!/bin/sh
PHPRC="/etc/php5/cgi/"
export PHPRC
PHP_DOCUMENT_ROOT="/var/www/clients/client2/web14"
export PHP_DOCUMENT_ROOT
# The variable PHP_FCGI_CHILDREN is onyl useful for lighty or nginx as apache 
# mod_fcgi will control the number of childs themself and never use the additional processes.
# PHP_FCGI_CHILDREN=1
# export PHP_FCGI_CHILDREN
PHP_FCGI_MAX_REQUESTS=1000
export PHP_FCGI_MAX_REQUESTS
exec /usr/bin/php-cgi \
 $1
Maybe something gone wrong during the latest ISPConfig upgrade?

Please, help me
Reply With Quote
  #20  
Old 30th August 2013, 22:01
Guavaman Guavaman is offline
Junior Member
 
Join Date: Aug 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by Skyflash View Post
When i publish a "normal" post that contains no external links, everything goes well. When i publish a post that contains external links, trackbacks or internal links with the full address (ie: http://www.skyflash.it/linked-older-post), my server hangs
I know this is an old thread, but this is exactly the same problem I'm seeing with all Wordpress sites hosted on GoDaddy.com. I haven't found a single other mention of this problem on the web. Did you ever find a resolution?

URLs in posts will eventually cause Apache or FastCGI to crash when saving the post. The more URL's in the post, the most likely a crash, but it appears to only happen with URL's of certain formats. For example, I've verified URL's with port numbers like :80 will always make it crash after only a few saves. Also, very long URL's over about 200 characters will also crash it quickly. This even happens with a fresh, clean Wordpress installation. Posts with no http:// in them never crash it.

GoDaddy is also using FastCGI and there's no way to disable it. The behavior of the crash makes me think something is going wrong on POST and that the URLs are being parsed or sanitized or something that's causing the apache processes to choke. I've done these tests on two other servers not on GoDaddy and they never crash.

I get these error very frequently in the logs:

Code:
[Thu Aug 29 16:07:04 2013] [4675188] [fcgid:warn] (9)Bad file descriptor: [client 98.210.131.207:3694] mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer http://site.com/test/wp-admin/post.php?post=22&action=edit&message=10

[Thu Aug 29 16:12:12 2013] [4675188] [fcgid:warn] (104)Connection reset by peer: [client 98.210.131.207:3721] mod_fcgid: error reading data from FastCGI server, referer http://site.com/test/wp-admin/post.php?post=22&action=edit&message=10
I've tried increasing memory, and setting fcgi variables in php5.ini have no effect.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 12:20
MySQL Error Nolan Installation/Configuration 12 16th February 2011 03:15
Need some Hints to "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" wahid HOWTO-Related Questions 10 25th August 2010 16:18
BIG Problem Postfix issue admins Installation/Configuration 11 13th November 2009 11:05
Webmail Relay Error palkat General 17 23rd April 2006 19:12


All times are GMT +2. The time now is 04:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.