Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd February 2012, 12:20
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Default

Hello ISP community,
can someone please confirm if ISPconfig 3.0.4.2 has problems with Php 5.3?

Has anyone tried php 5.3.9?

Is there any easy way updating 5.2.6 to 5.3 (read: apt-update?).

Thank you,
V.
Reply With Quote
Sponsored Links
  #12  
Old 2nd February 2012, 12:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

ISPConfig works fine with any php 5.3 version. The message that one user posted here was caused by a wrong error_reporting level in his php.ini.

Quote:
Is there any easy way updating 5.2.6 to 5.3 (read: apt-update?).
Yes, see other posts in this thread about dotedb.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
vaio (2nd February 2012)
  #13  
Old 2nd February 2012, 13:53
vaio vaio is offline
Member
 
Join Date: Nov 2010
Posts: 48
Thanks: 21
Thanked 1 Time in 1 Post
Post

Ok, i have found out solution and am sharing with you..

For Debian LENNY:

1. Open sources list:
Code:
vi /etc/apt/sources.list
2. Add lines to list -> Press 'a' and in new line insert (i supose you have VI editor, otherviwe use appropriate key):
Code:
deb http://packages.dotdeb.org lenny all
3. Save and exit -> Press ':wq' to save and exit in VI editor

4. Import dotdeb keys:
Code:
wget http://www.dotdeb.org/dotdeb.gpg
cat dotdeb.gpg | apt-key add -
5. Update:
Code:
apt-get update
apt-get upgrade
apt-get dist-upgrade
Follow on screen instructions...

You will get latest stable version for lenny: PHP 5.2.17 if you want 5.3.x, than add these lines in apt sources:

Code:
deb http://php53.dotdeb.org oldstable all
deb-src http://php53.dotdeb.org oldstable all
If you use Debian Squeeze, than instead of 'oldstable' use 'stable' in apt list. Other is the same...

P.s: I am not responsible for any issues, it is just my experience shared with you...

To check PHP version, use: 'php -v' in terminal...

Regards,
Vaio
Reply With Quote
  #14  
Old 3rd February 2012, 12:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by vaio View Post
Hello ISP community,
can someone please confirm if ISPconfig 3.0.4.2 has problems with Php 5.3?

Has anyone tried php 5.3.9?
ISPConfig works fine for me with PHP 5.3.9 (on Debian testing).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 14th July 2012, 11:22
PermaNoob PermaNoob is offline
Senior Member
 
Join Date: Jan 2007
Posts: 194
Thanks: 12
Thanked 4 Times in 4 Posts
Default

trying to upgrade php 5.2.6 to 5.3 using vaio's method and it appears dotdeb.org no longer offers the php 5.3 packages for Lenny.

Any other safe way to upgrade to php 5.3?

I'm using ispconfig 3 on Lenny.

(trying to install ownCloud, but it required php 5.3)

Last edited by PermaNoob; 14th July 2012 at 11:29.
Reply With Quote
  #16  
Old 28th December 2012, 16:11
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 3 Times in 3 Posts
Default

Also still trying to update my old lenny server. to php5.2.7 or higher.

I have red the info at dotdeb.org
Code:
deb http://packages.dotdeb.org squeeze all
deb-src http://packages.dotdeb.org squeeze all
But because its an older debian version I used

Code:
deb http://archives.dotdeb.org/ lenny all
deb-src http://archives.dotdeb.org/ lenny all
and
Code:
deb http://packages.dotdeb.org oldstable all
deb-src http://packages.dotdeb.org oldstable all
but getting a 404 error.

Code:
server1:~# wget http://archives.dotdeb.org/dotdep.gpg
--2012-12-28 15:50:22--  http://archives.dotdeb.org/dotdep.gpg
Resolving archives.dotdeb.org... 88.190.17.153
Connecting to archives.dotdeb.org|88.190.17.153|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-12-28 15:50:22 ERROR 404: Not Found.
If I check the dotdeb site the php for lenny is located at:
HTML Code:
http://archives.dotdeb.org/dists/lenny/php5/.....
So I am guessing I have to chanse the links in the sources list but I dont know witch format to use?
Can anybody give me a hand please....

TIA
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #17  
Old 31st December 2012, 13:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Use http://www.dotdeb.org/dotdeb.gpg instead of http://archives.dotdeb.org/dotdep.gpg (see http://www.dotdeb.org/instructions/ ).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
ispconfig php 5 errors itamarjp Installation/Configuration 8 25th April 2008 10:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 09:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.