Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 26th January 2012, 09:23
mike_p mike_p is offline
Senior Member
 
Join Date: Mar 2010
Location: Surrey, England
Posts: 140
Thanks: 9
Thanked 28 Times in 17 Posts
Default Bizarre problem solved!

I don't know what else to give as a title to this thread, but I thought it's worth posting.

A few weeks ago I started having strange problems with email accounts and DNS.

After a lot of work I realised that at some point overnight the /tmp directory was getting set with restrictive permissions, preventing certain services from using it.

As a temporary fix I set a cron job to reset the permissions.

Now I've found out what was doing the damage!

The new version of ISPConfig has a service to backup websites. It's run frm cron_daily.php. During the proces it checks the permissions of the backup folder and resets them if neccessary. Yes, you've guessed it, my backup directory was set to /tmp so ISPConfig was resetting permissions for the tmp directory.

Problem solved by setting the backup folder in ISPConfig (system:server configuration:server:...) to something other than /tmp!

Hope this solves problems for someone else!
Reply With Quote
The Following User Says Thank You to mike_p For This Useful Post:
till (26th January 2012)
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
postfix/trivial-rewrite digitalage HOWTO-Related Questions 19 13th March 2013 19:02
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20


All times are GMT +2. The time now is 02:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.