Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th January 2012, 04:36
sfunk1x sfunk1x is offline
Member
 
Join Date: Jun 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default Centos 5.x, SVN & Apache

Hey all,


I'm having a heck of a time getting subversion to work with my Centos 5.x & Apache setup. It seems as though I can import when I'm at console, but when I try to connect to the server form my workstation (to make a commit via subclipse), I get a lot of 403 errors showing up in the logs. let me break it down in steps:


Version: 2.6.18-164.6.1.el5xen GNU/Linux

/etc/httpd/conf.d/subversion.conf:


Code:
LoadModule dav_svn_module     modules/mod_dav_svn.so
LoadModule authz_svn_module   modules/mod_authz_svn.so

<Location /repos>
       	DAV svn
        SVNParentPath /var/www/html/www.sfunk1x.com/svn
#	SVNParentPath /svn/repos
        AuthType Basic
        AuthName "sfunk1x repos"
        AuthUserFile /var/www/html/www.sfunk1x.com/svn/repos/conf/passwd
        Require valid-user
</Location>
I used svnadmin to create the repos folder underneath /var/www/html/www.sfunk1x.com/svn. I chown'd apache.apache to svn -R. I also set chmod 775 to repos -R.

I used htpasswd to create the passwd file in /var/www/html/www.sfunk1x.com/svn/repos/conf.

When I attempt a checkin or checkout from http://www.sfunk1x.com/repos/Java1_Ch8, I get the following errors:

Code:
svn: E000002: Unable to connect to a repository at URL 'http://www.sfunk1x.com/repos/Java1_Ch8'
svn: E000002: Could not open the requested SVN filesystem
When I perform a checkin or checkout locally (on the server) via the /tmp folder, everything works fine. The webserver seems to be working fine (all the virtual hosts are responding), so I'm at a loss as to what is wrong. Even when i disable the authentication, the same errors pop up.

From the www.sfunk1x.com-error_log:

Code:
[Sat Jan 21 20:39:25 2012] [error] [client 98.246.142.37] (20014)Internal error: Can't open file '/svn/repos/Java1_Ch8/format': No such file or directory
[Sat Jan 21 20:39:25 2012] [error] [client 98.246.142.37] Could not fetch resource information.  [500, #0]
[Sat Jan 21 20:39:25 2012] [error] [client 98.246.142.37] Could not open the requested SVN filesystem  [500, #2]
[Sat Jan 21 20:39:25 2012] [error] [client 98.246.142.37] Could not open the requested SVN filesystem  [500, #2]
From the www.sfunk1x.com-access_log:

Code:
98.246.142.37 - - [21/Jan/2012:20:39:18 -0800] "OPTIONS /repos/Java1_Ch8 HTTP/1.1" 401 481
98.246.142.37 - sfunk1x [21/Jan/2012:20:39:25 -0800] "OPTIONS /repos/Java1_Ch8 HTTP/1.1" 500 234
I'm really at a loss here. Anyone have any ideas as to where I should start looking? I appreciate any help thrown my way!
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 5.x, Subversion & Apache sfunk1x Installation/Configuration 0 22nd January 2012 05:48
sessions not being saved gavimobile General 6 15th January 2012 15:05
Problems connecting my HTC Desire outgoing mail client to Postfix and ISP Config 2 j.smith1981 Server Operation 6 12th July 2010 19:07
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33


All times are GMT +2. The time now is 10:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.