Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 23rd January 2012, 12:11
fmmarzoa fmmarzoa is offline
Junior Member
 
Join Date: Jan 2010
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problems with mod rewrite and existing directory

Hi,

I have two webservers, one for development with Ubuntu 11.10 and other for deployment with Ubuntu 10.04. Both runs apache with similar configuration, and the only relevant difference I think it is that deployment one uses ISPConfig 3, so I think my problem may be related with that (perhaps not, indeed...).

Well, I have in both servers the following .htaccess at website root directory:

RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php [L]

As you may know, it tells to apache that if the requested filename is neither a file, nor a directory and not a symlink, it should redirect request to index.php.

It works as expected on my development site without ISPConfig 3, but it does NOT on my deployment one with it. The problem is that it redirects to index.php even a folder that yet exists.

So, I have an /admin folder there with the backend office of the site. In the development site if I do:

http://mydomain.com/admin/

It works as expected, but in deployment one it redirects to index.php as if it were not a directory. But the folder is there and it IS a directory without any doubt. So I think that mod rewrite directives may be failing for some reason, but what???

Thanks a lot in advance,
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with emails server (postfix, courier, mysql and squirrelmail) cleber_maverick Server Operation 5 6th November 2011 13:11


All times are GMT +2. The time now is 12:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.