Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 20th January 2012, 17:57
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 65
Thanks: 15
Thanked 5 Times in 5 Posts
Default Big warning about network configuration option in Ubuntu on a VPS

See the button that says "Network Configuration" under "Server Config"?

"Network Configuration The network configuration option is only available for Debian and Ubuntu Servers. Do not enable this option if your network interface is not eth0."

I have a ubuntu 11.10 server and the interface is eth0. It's a Xen-based VPS on a vlan.

I pushed the button.

There followed 6 hours of hell while I worked overnight trying to get to my now-dead server. Couldn't even connect to do an emergency rollback or reboot. At 8am, a very helpful and friendly senior admin spent nearly an hour of his time (which he didn't have to do) recovering the system.

We managed to get it back to being able to connect on the 3 IP addresses we had before, but he said the numbers were "all over the place". It had set things like the gateway to 192.168.0.1, and when he tried to to ifup, it said something like the interface couldn't be linked. We couldn't add any more.

In the end, we just took the whole /www dir, switched to a new server and I re-installed everything (was going to do it anyway, just not quite then!)

Incredibly annoyingly, I made a notepad full of notes about what he said and what it had changed to, but everything in /etc/interfaces was wrong, from the subnet mask to the gateway to the broadcast - all totally wrong for the VPS!

So, it MIGHT be something to do with it being a VPS, but unless you really REALLY need to push that button, or have a backup plan, just don't!
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
ispconfig 3, network

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Being Spammed/Hacked/Probed not sure PLEASE HELP! kresser General 10 29th October 2010 18:25
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 13:47
Unable to connect to Mysql mbascombe Installation/Configuration 12 10th January 2010 23:46
Add ons for ISPConfig 3 virtue Installation/Configuration 24 16th October 2009 18:30
So close to getting 3D on my ATI graphics card, please help me finish thirtythree HOWTO-Related Questions 6 27th September 2007 23:04


All times are GMT +2. The time now is 03:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.