#1  
Old 6th March 2006, 16:35
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Lightbulb mod_mono apache 2.2

Hello

i want to run apache asp.net
i followed a tut to do it.
i have installed
-apache 2.2
-mono
-xsp

everything works like a charm but when i was compiling mod_mono the config script can't find out whitch version my apache is my ./configure command is

./configure --prefix=/var/server/mod_mono --with-apxs=/var/server/webserver/apache/bin/apxs

then i got
checking for --with-apxs... /var/server/webserver/apache/bin/apxs executable, good
checking for --with-apr-config... not specified
checking for Apache libexec directory... /var/server/webserver/apache/modules
checking for Apache sysconf directory... /var/server/webserver/apache/conf
checking for Apache include directory... -I/var/server/webserver/apache/include
checking Apache version... configure: error: Confused on apache version. Please report this and send config.log

i have also tryed
./configure --prefix=/var/server/mod_mono --with-apxs=/var/server/webserver/apache/bin/apxs --with-apr-config=/var/server/webserver/apache/bin/apr-1-config

but then i says that my apache version is 1.3 and thats not correct

i don't know how to solve it and i can't find anything about it on google
my config.log files can you find here
try 1
http://www.colddot.nl/config_try-fault.log.txt
try 2
http://www.colddot.nl/config_try-version-1.3.log.txt

greets kevin
__________________
2B or not 2B (a pro)
Reply With Quote
Sponsored Links
  #2  
Old 6th March 2006, 18:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Does mod_mono already support Apache 2.2? It's pretty new...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th March 2006, 18:58
ColdDoT ColdDoT is offline
Senior Member
 
Join Date: Jan 2006
Location: Netherland
Posts: 178
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to ColdDoT
Default

on the site sais it will.
but on what searching. no it don't

but is there maybe a work around ?
__________________
2B or not 2B (a pro)
Reply With Quote
  #4  
Old 4th April 2006, 14:25
22hosting 22hosting is offline
Junior Member
 
Join Date: Apr 2006
Posts: 26
Thanks: 0
Thanked 1 Time in 1 Post
Default

I have to say that I can confirm this error as well. Hence *BUMP* this thread. Does anyone have a solution yet?
________
Live sex

Last edited by 22hosting; 22nd August 2011 at 12:58.
Reply With Quote
  #5  
Old 4th April 2006, 15:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I guess I have to try myself and write a tutorial about it some day...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 23rd May 2006, 02:58
mintaka mintaka is offline
Junior Member
 
Join Date: May 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Not so much a solution, but after wasting all night on this I do at least have a work-around. Had the same issue myself - mod_mono doesn't compile against Apache 2.2.2 - it seems the apache version checking routine invoked when running mod_mono's ./configure fails to compile now resulting in the erroneous reporting of version 1.3:

Quote:
configure:20643: checking Apache version
configure:20665: gcc -c -g -O2 -I/usr/local/httpd/apache-2.2.2/include conftest.c >&5
In file included from /usr/local/httpd/apache-2.2.2/include/apr_general.h:28,
from /usr/local/httpd/apache-2.2.2/include/ap_release.h:24,
from conftest.c:51:
/usr/local/httpd/apache-2.2.2/include/apr.h:270: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'apr_off_t'
configure:20671: $? = 1

Didn't have the skills to fix that, so I just forced the selection of Apache 2.2 by editing the file "configure" inside the mod_mono source directory. You'll find a couple of lines that say:

APACHE_VER=1.3

Change those lines to 2.2 and ./configure sets the build up for a successful compile.

Hope this helps.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ignore apache error logs? lerra Installation/Configuration 4 10th February 2006 23:28
Apache Downgrade!!!! cybereatl Server Operation 4 4th February 2006 06:31
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 14:01
install apache 1.3 on FC 4 superg Server Operation 1 22nd December 2005 17:44
Apache 1.3 Support SleeperZ General 3 9th November 2005 11:10


All times are GMT +2. The time now is 09:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.