Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 16th January 2012, 03:23
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default ISPConfig 3 not following website path

Hello,

I was having this problem a few weeks ago with sites not launching in ISPConfig 3. Apache is not following the filepath to the site. Basically, this is the only error from httpd that I need show as it is redundant:

[client 173.93.151.XXX] File does not exist: /var/www/html/wp-admin

The LAN ip is 192.168.11.7 Here is the output of # ifconfig


eth0 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.6 Bcast:192.168.11.255 Mask:255.255.255.0
inet6 addr: fe80::6efd:b9ff:fe44:4860/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14241 errors:1 dropped:0 overruns:0 frame:0
TX packets:11553 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1738551 (1.6 MiB) TX bytes:7339018 (6.9 MiB)
Interrupt:10 Base address:0x8c00

eth0:1 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.7 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:2 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.8 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:3 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.9 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:4 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.10 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:5 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.11 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:15057 errors:0 dropped:0 overruns:0 frame:0
TX packets:15057 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1552877 (1.4 MiB) TX bytes:1552877 (1.4 MiB)

And the output of # ifconfig -a

eth0 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.6 Bcast:192.168.11.255 Mask:255.255.255.0
inet6 addr: fe80::6efd:b9ff:fe44:4860/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14271 errors:1 dropped:0 overruns:0 frame:0
TX packets:11572 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1741363 (1.6 MiB) TX bytes:7343152 (7.0 MiB)
Interrupt:10 Base address:0x8c00

eth0:1 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.7 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:2 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.8 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:3 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.9 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:4 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.10 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

eth0:5 Link encap:Ethernet HWaddr 6C:FD:B9:44:48:60
inet addr:192.168.11.11 Bcast:192.168.11.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Interrupt:10 Base address:0x8c00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:15108 errors:0 dropped:0 overruns:0 frame:0
TX packets:15108 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1558025 (1.4 MiB) TX bytes:1558025 (1.4 MiB)

These IPs have been added to the server ip list in the ispconfig panel. And restarting apache delivers this (which is a good sign)

]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.7:443 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.6:80 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.6:443 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.10:80 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.10:443 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.9:80 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.9:443 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.8:80 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost 192.168.11.8:443 has no VirtualHosts
[Sun Jan 15 21:14:18 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
[ OK ]

And the contents of the site trying to launch in sites-enabled:

<Directory /var/www/domain.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost 192.168.11.7:80>
DocumentRoot /var/www/clients/client1/web1/web

ServerName domain.com
ServerAlias www.domain.com
ServerAdmin webmaster@domain.com

ErrorLog /var/log/ispconfig/httpd/domain.com/error.log


ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 502 /error/502.html
ErrorDocument 503 /error/503.html

<IfModule mod_ssl.c>
</IfModule>
<Directory /var/www/domain.com/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</Directory>

<IfModule mod_ruby.c>
<Directory /var/www/domain.com/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>

<IfModule mod_python.c>
<Directory /var/www/domain.com/web>
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

# cgi enabled
<Directory /var/www/clients/client1/web1/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/www/clients/client1/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web1 client1
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# suphp enabled
<Directory /var/www/clients/client1/web1/web>
<IfModule mod_suphp.c>
suPHP_Engine on
# suPHP_UserGroup web1 client1
AddHandler x-httpd-suphp .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-suphp
</IfModule>
</Directory>


# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web1 client1
</IfModule>

<IfModule mod_dav_fs.c>
# Do not execute PHP files in webdav directory
<Directory /var/www/clients/client1/web1/webdav>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
</Directory>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>


</VirtualHost>

The real domain name has been replaced with "domain.com"

Thanks for the help.
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
file path, ispconfig 3, networking

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Redirect a domain. ISPConfig is adding a / at the end of the path... voltron81 Installation/Configuration 4 24th May 2010 15:20
making website in ispconfig pinguinito General 0 15th May 2009 08:47
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 01:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.