Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th January 2012, 22:34
hargz hargz is offline
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Multiple Sites & IP's - ISPCONFIG 3

I'm running ISPConfig 3.0.2.1 and Centos 5.7

I have 3 IP Addresses and 3 Websites.

Everything was set up fine and website A and IP A have been running fine.
Today I have added two more IP's and two more Websites, again also fine.

In ISP config I have assigned an IP address to each website and the main website websiteA.co.uk is still running fine.

The problem is when I go to websiteB.co.uk it takes me to:

websiteB.co.uk/www.websiteA.co.uk

And therefore displays Website A's 404 message.

This is also the same if I go to website B's IP address.

Can someone please shed some light to where i'm going wrong.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 15th January 2012, 12:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
 
Default

I guess you entered a redirect path www.websiteA.co.uk in www.websiteB.co.uk. If the path does not start with http://, it gets interpreted by apache as filesystem folder, so apache redirects you to the folder www.websiteA.co.uk in the website www.websiteB.co.uk.

To fix that, change the redirect path to:

http://www.websiteA.co.uk
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 18:17
ISPCONFIG 3 - Multiple Sites on the same IP? astewart Developers' Forum 3 28th October 2008 15:32
ISPConfig with multiple CMSs Bebop17 General 4 3rd May 2008 16:52
multiple IPs and Vhosts_ispconfig.conf jag7720 Installation/Configuration 1 14th February 2008 11:25
Multiple IP's Under ISPConfig giganet Server Operation 2 4th October 2007 05:23


All times are GMT +2. The time now is 20:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.