Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 9th January 2012, 20:11
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default SPAM over assigned policy's kill level not deleted automatically

I created a new "Spamfilter Policy" under Email -> Policy, but it seems as though the policy is not being applied to incoming mail.

My understanding is that if the "SPAM kill level" is set to 15, then messages with a SPAM score >= 15 will be discarded.

There seems to be conflicting information regarding the following directive in /etc/amavis/conf.d/50-user:

Code:
$final_spam_destiny = D_DISCARD;
Some say that this directive must be enabled in this specific configuration file for automatic SPAM deletion to occur, while others (e.g., Till) say that this directive is irrelevant, as ISPConfig overrides this value on a per-policy-assignment basis.

Quote:
Originally Posted by till View Post
The spam kill level is set in ISPConfig for every policy individually and not in this file. the setting in the rc2 was wrong as it caused nmail to be deleted even if spam scanning was deactivated for an account or domain.
Quote:
Originally Posted by till View Post
...
Anyway, the configuration that you do in ispconfig when you select a policy overrides these, so they do not matter for all emails domains or mailboxes that you assigned a policy.
Quote:
Originally Posted by prisfeo View Post
thanks Falko..
check also this strange behaviour i posted here:

http://www.howtoforge.com/forums/showthread.php?t=42965
(about the "double" amavisd.conf files)

since it can lead not to use correctly amavis...
i think it can be related to some installation issue.



thanks Till..yes i confirm since i have changed & made some
tests in that direction..



uhmm..me too thought that, but from the test i made, have to say that it does not ovveride..
let me explain:

in the amavis conf file i have deleted the two statements groups above
and wrote one group with the following settings:

$final_virus_destiny = D_DISCARD;
$final_spam_destiny = D_DISCARD;
$final_banned_destiny = D_BOUNCE;
$final_bad_header_destiny = D_PASS;

well,
now if i change
$final_spam_destiny = D_DISCARD;
into
$final_spam_destiny = D_PASS;

and i send a spam gtube test email to account inside ispconfig,
(see above ispconfig tab settings), are not killed (deleted), but
tagged as "SPAM: subject"
even if "SPAM kill level: 6.9"

only putting $final_spam_destiny = D_DISCARD;
i obtain that email with spam hits > 6.9 are killed(deleted)..

so, do you think it's not normal or there's something wrong
into my ispconfig/amavis integration ?
Anyway, the line in question is un-commented in my amavis configuration.

However, messages with an X-Spam-Score header well over the kill level are not deleted automatically. Here are the headers from one such email message:

Code:
X-Virus-Scanned: Debian amavisd-new at example.com
X-Spam-Flag: YES
X-Spam-Score: 27.428
X-Spam-Level: ***************************
X-Spam-Status: Yes, score=27.428 tagged_above=1 required=4.5
tests=[BAYES_99=3.5, DATE_IN_FUTURE_24_48=2.048,
DKIM_ADSP_CUSTOM_MED=0.001, DRUGS_ERECTILE=1.994, DRUG_ED_CAPS=0.936,
FORGED_YAHOO_RCVD=1.63, FREEMAIL_FROM=0.001, NML_ADSP_CUSTOM_MED=0.9,
RCVD_IN_BRBL_LASTEXT=1.449, RCVD_IN_PBL=3.335, RCVD_IN_XBL=0.375,
RDNS_NONE=0.793, SUBJECT_DRUG_GAP_C=2.14, SUBJ_ALL_CAPS=1.506,
SUBJ_BUY=0.639, URIBL_DBL_SPAM=1.7, URIBL_JP_SURBL=1.25,
URIBL_SBL=1.623, URIBL_WS_SURBL=1.608] autolearn=spam
Screen captures of the Spampolicy Filter settings, and of the individual mailbox's Spamfilter setting are attached.

The Spamfilter setting for the domain is set to "Normal", but my understanding is that the Spamfilter setting for the specific mailbox should override the domain-level setting.

Am I missing something?
Attached Images
     
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
amavis, filter, kill level, policy, spam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
spam mails not going to junk folder. pawan Installation/Configuration 4 6th June 2011 21:26
Spamfilter policy - question about spam actions prisfeo Installation/Configuration 4 2nd February 2010 17:17
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 15:31
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 18:37
slow download through webserver problem snewp Technical 14 9th May 2008 06:25


All times are GMT +2. The time now is 13:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.