Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th January 2012, 01:23
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default ISPConfig 3.0.4.1 won't launch site

Hello,

I had this same problem before with ispconfig not launching a site with the repeated error:

File does not exist: /var/www/html/example-file

Adding an empty index.html in /var/ww/html/ fixed this. Now it doesn't.

I know the IP is correct. In /etc/httpd/conf/sites-enabled this site's ip is placed correctly.

Running # ifconfig shows the ip
Running # ifconfig -a shows the ip as readily available.

I am remotely logging into ISPConfig 3.0.4.1 where the site is held on the same IP, so I know that it is working fine (the ip).

For some reason, ISPConfig will not recognize the correct directory path, hence the repeated same error in the logs

File does not exist: /var/www/html/wp-admin
File does not exist: /var/www/html/wp-login.php

...the list goes on. ALL errors are: File does not exist: /var/www/html/(various file here)

Any help would be great. I really need to get this site launched. Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 9th January 2012, 11:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Quote:
For some reason, ISPConfig will not recognize the correct directory path, hence the repeated same error in the logs
The routing of incoming requests is done by the webserver (apache) and not ispconfig. ISPConfig is a hosting controlpanel, so it writes configuration files. ISPConfig is not a webserver.

Quote:
File does not exist: /var/www/html/wp-admin
File does not exist: /var/www/html/wp-login.php
This happens when apache can not find a vhost with the correct IP / domain combinations. The reasons can be:

- Typo in the domain name.
- Wrong IP address selected in the website settings.
- * selected instaed of the IP address without having a namevirtualhost directive for * . Try to select the IP instaed of *.
- You try to access the site with www.domain.tld instead of domain.tld but missed to activate the auto-subdomian www settings in the website.
- You use the IP address to access the site instead of the domain name.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th January 2012, 15:09
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Hi Till,

Unfortunately, the answer to all of these is that they are set properly. I decided to tear down the server and put ISPConfig 2 on instead, using the same set-up as far as my network and OS were concerned. Using the same IPs, ISPConfig will launch sites with no problems at all. Unfortunately I will be losing some functionality that is available in 3 versus 2, but need it to work more importantly. Site should have no problem now in ISPConfig 2 (in theory), as the default index.html shows just fine on all domains. Here are the two issues I am having with ISPConfig 2:

1. The mail will not authenticate (used The Perfect Server Fedora 14 x86_64 with ISPConfig 2) Here are two snippets of the maillog:

8 22:33:10 hostfive postfix/smtpd[28967]: setting up TLS connection from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]
Jan 8 22:33:10 hostfive postfix/smtpd[28967]: Anonymous TLS connection established from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: TLSv1 with cipher DHE-RSA-CAMELLIA256-SHA (256/256 bits)
Jan 8 22:33:12 hostfive postfix/smtpd[28967]: warning: SASL authentication failure: Password verification failed
Jan 8 22:33:12 hostfive postfix/smtpd[28967]: warning: cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: SASL PLAIN authentication failed: authentication failure
Jan 8 22:33:14 hostfive postfix/smtpd[28967]: warning: cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: SASL LOGIN authentication failed: authentication failure
Jan 8 22:33:29 hostfive postfix/smtpd[28967]: warning: SASL authentication failure: Password verification failed
Jan 8 22:33:29 hostfive postfix/smtpd[28967]: warning: cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: SASL PLAIN authentication failed: authentication failure
Jan 8 22:33:30 hostfive postfix/smtpd[28967]: warning: cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: SASL LOGIN authentication failed: authentication failure
Jan 8 22:35:12 hostfive postfix/smtpd[28967]: lost connection after AUTH from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]
Jan 8 22:35:12 hostfive postfix/smtpd[28967]: disconnect from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]
Jan 8 22:35:30 hostfive postfix/smtpd[28967]: table hash:/etc/postfix/virtusertable(0,lock|fold_fix) has changed -- restarting
Jan 8 22:35:30 hostfive postfix/smtpd[29633]: connect from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]
Jan 8 22:35:30 hostfive postfix/smtpd[29633]: setting up TLS connection from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]
Jan 8 22:35:30 hostfive postfix/smtpd[29633]: Anonymous TLS connection established from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: TLSv1 with cipher DHE-RSA-CAMELLIA256-SHA (256/256 bits)
Jan 8 22:35:32 hostfive postfix/smtpd[29633]: warning: SASL authentication failure: Password verification failed
Jan 8 22:35:32 hostfive postfix/smtpd[29633]: warning: cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: SASL PLAIN authentication failed: authentication failure
Jan 8 22:35:34 hostfive postfix/smtpd[29633]: warning: cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]: SASL LOGIN authentication failed: authentication failure
Jan 8 22:35:55 hostfive postfix/smtpd[29633]: disconnect from cpe-173-093-151-171.sc.res.rr.com[173.93.151.171]
Jan 8 22:37:33 hostfive dovecot: imap-login: Aborted login (no auth attempts): rip=173.93.151.171, lip=192.168.11.17
Jan 8 22:37:33 hostfive dovecot: imap-login: Aborted login (no auth attempts): rip=173.93.151.171, lip=192.168.11.17
Jan 8 22:37:33 hostfive dovecot: imap-login: Aborted login (no auth attempts): rip=173.93.151.171, lip=192.168.11.17

8 23:04:37 hostfive dovecot: pop3-login: Aborted login (auth failed, 1 attempts): user=<admin@hostwithsupport.com>, method=PLAIN, rip=72.15.150.115, lip=192.168.11.17
Jan 8 23:20:16 hostfive dovecot: pop3-login: Aborted login (auth failed, 1 attempts): user=<admin@hostwithsupport.com>, method=PLAIN, rip=72.15.150.115, lip=192.168.11.17
Jan 8 23:36:00 hostfive dovecot: pop3-login: Aborted login (auth failed, 1 attempts): user=<admin@hostwithsupport.com>, method=PLAIN, rip=72.15.150.115, lip=192.168.11.17
Jan 8 23:51:48 hostfive dovecot: pop3-login: Aborted login (auth failed, 1 attempts): user=<admin@hostwithsupport.com>, method=PLAIN, rip=72.15.150.115, lip=192.168.11.17
Jan 8 23:52:53 hostfive dovecot: pop3-login: Disconnected (auth failed, 1 attempts): user=<admin@hostwithsupport.com>, method=PLAIN, rip=209.85.212.23, lip=192.168.11.17

2. phpMyAdmin - no accessibility. Per the manual, there is supposed to be access in the CPanel under "tools" for phpMyAdmin for admin, reseller, and clients. Not present in all three. Then trying to access phpMyAdmin like this doesn't work either:

http://hostone.example.com:81/phpmyadmin (with or without https)

http://hostone.example.com/phpmyadmin (with or without https)

http://newdomain.com:81/phpmyadmin

http://newdomain/phpmyadmin

Also tried all six with phpmyadmin and phpMyAdmin. ERRORS:

Either /phpmyadmin not found on this server or:

you do not have permission to access /phpmyadmin on this server

Here is the error_log for apache that has anything to do with phpmyadmin:

[Mon Jan 09 01:07:52 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/php-my-admin
[Mon Jan 09 01:07:52 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.2.3
[Mon Jan 09 01:07:52 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.2.6
[Mon Jan 09 01:07:53 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.1
[Mon Jan 09 01:07:53 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.4
[Mon Jan 09 01:07:53 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.5-rc1
[Mon Jan 09 01:07:54 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.5-rc2
[Mon Jan 09 01:07:54 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.5
[Mon Jan 09 01:07:54 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.5-pl1
[Mon Jan 09 01:07:54 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.6-rc1
[Mon Jan 09 01:07:54 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.6-rc2
[Mon Jan 09 01:07:55 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.6
[Mon Jan 09 01:07:55 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.7
[Mon Jan 09 01:07:55 2012] [error] [client 77.243.224.200] File does not exist: /var/www/sharedip/phpMyAdmin-2.5.7-pl1
Reply With Quote
  #4  
Old 9th January 2012, 15:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,478
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Please dont post ISPConfig 2 questions in the ISPConfig 3 forum. Make a new thread in the ISPConfig 2 forum instaed if you have nay ISPConfig 2 related questions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 9th January 2012, 15:15
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
 
Default

Till,

We were talking about ISPConfig 3 to begin with. Wouldn't it have been easier to just answer the question?
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3.0.4.1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with new site in ISPConfig OVG Installation/Configuration 1 22nd December 2010 15:52
ISPConfig 3 installed on Debian Lenny... and now... how to create a site? manarak General 6 19th May 2009 16:34
added site but ispconfig doesnt created a dir dr_dbox General 6 26th June 2008 14:25
ISPConfig administration site caching images satyannair Installation/Configuration 4 8th April 2008 15:37
site works but ISPConfig login gone? Boon-Dog-Danny Installation/Configuration 6 4th August 2006 13:01


All times are GMT +2. The time now is 03:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.