Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd January 2012, 07:56
daveporter daveporter is offline
Junior Member
 
Join Date: Dec 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default used chown and now domain is broken !

Hi All,

First post here!

I am using ISPConfig on Linode and was having problems getting wordpress updates from within admin working.

Someone suggested entering this chown command:
sudo chown -R www-data:www-data /var/www/

And now the site is broken!
(Error below!)

Can anyone help with fixing this please ?
Is it as easy as reversing the chown command ( if so what would the syntax be ?)
TIA Dave

>>>>>>>>>>>>>>>>>>>>>>
ERROR 500 - Internal Server Error!
The following error occurred:
The requested URL caused an internal server error.
If you get this message repeatedly please contact the webmaster.
Reply With Quote
Sponsored Links
  #2  
Old 3rd January 2012, 09:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Quote:
Someone suggested entering this chown command:
sudo chown -R www-data:www-data /var/www/
This was a bad suggestion, as this breaks all exising sites on the server.

Quote:
Is it as easy as reversing the chown command ( if so what would the syntax be ?)
Thats not that easy as the different subfolders in /var/www have different owners. How many websites do you host on that server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd January 2012, 09:04
daveporter daveporter is offline
Junior Member
 
Join Date: Dec 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the prompt reply !

I have two domains currently, but only one is important!
(The other is working - but it is just a simple index.html - nothing else!)

Regards, Dave
Reply With Quote
  #4  
Old 3rd January 2012, 09:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Ok. To fix your setup, take a look in the website settings in ispconfig, there you can find the username and group of each website on the options tab. Note down the domain name and user and group for both sites.

then execute this command for each site:

chown -R web1:client0 /var/www/domain.tld

replace web1 with the user of the website and client0 with the group of the website and domain.tld with the doamin name of the website.

Regarding your original problem with the wordpress updates, ensure that you use the php mode "php-fcgi" in the website settings and that the suexec checkbox is enabled, this ensures that wordpress can write into the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 3rd January 2012, 09:54
daveporter daveporter is offline
Junior Member
 
Join Date: Dec 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks so much Till - will follow that and let you know how I go !
Dave
Reply With Quote
  #6  
Old 3rd January 2012, 10:47
daveporter daveporter is offline
Junior Member
 
Join Date: Dec 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oops Sorry - I should read more slowly - I see these settings are in the ISPconfig interface - but I can't see the user and group settings !
& Can't see an Options tab page anywhere...

Update: I purchased the ISPConfig manual, and can see an image with an Options tab page - but I don't have that on mine ! At least I'm not going mad

Also PHP was set to Fast-CGI and the suexec checkbox is enabled !

Dave


Ignore below!
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
Sorry for not working this out, but where is the config file that stores this information ?

I've been googling and searching and the only reference to config files I can find is:
/usr/local/ispconfig/interface/lib/config.inc.php
&
/usr/local/ispconfig/server/lib/config.inc.php

And neither seems to contain anything like what you described !

TIA, Dave

Last edited by daveporter; 3rd January 2012 at 11:06.
Reply With Quote
  #7  
Old 3rd January 2012, 11:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Quote:
I see these settings are in the ISPconfig interface - but I can't see the user and group settings !
& Can't see an Options tab page anywhere...
login as admin user, not as client or reseller. Then go to sites, click on the website you want to repair and then you will see several tabs, go to the options tab and there you will see the username and group of the website.


Quote:
Sorry for not working this out, but where is the config file that stores this information ?
This information is in the mysql database, not a config file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 3rd January 2012, 11:36
daveporter daveporter is offline
Junior Member
 
Join Date: Dec 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks I worked that out eventually !

OK so that has changed things - I now get an error:
No input file specified
When I access the site.

But now my Linode is also not behaving, so I'l sort that out first...
(I Don't get the ISPConfig login screen !)

Cheers, Dave
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.