Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd January 2012, 17:28
ichpen ichpen is offline
Junior Member
 
Join Date: Dec 2011
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
 
Default ISPConfig - email piping to osticket

Hoping someone here can help.

Running ubuntu 11.10 and latest ispconfig 3.

I have a mailbox support@mydomain.com that will be used for email piping.

I'm trying to get the osticket WP plugin working with email piping but no joy. I've run through many posts and tried the following:

Custom email filter recipe: to "|/var/www/clients/client4/web4/web/wp-content/plugins/zingiri-tickets/osticket/upload/api/pipe.php"

This produces a rather hard to catch error in the mail.log vmail[5000] no recipient found in header ....


I've tried creating a system user helpdesk, then adding a new alias
helpdesk: "|/var/www/clients/client4/web4/web/wp-content/plugins/zingiri-tickets/osticket/upload/api/pipe.php"

Then using cc "!helpdesk@localdomain" in custom rules (ispconfig).

This actually gave me a proper message after an error as below:


Jan 2 11:07:19 server1 postfix/sendmail[15166]: fatal: nobody(65534): No recipient addresses found in message header

Jan 2 11:07:19 server1 postfix/local[15162]: 189A615A1F65: to=<helpdesk@localhost>, relay=local, delay=0.08, delays=0.02/0.01/0/0.05, dsn=2.0.0, status=sent (delivered to command: /var/www/clients/client4/web4/web/wp-content/plugins/zingiri-tickets/osticket/upload/api/pipe.php)

But again, no ticket is created in osticket. No other errors in syslog or mail.log.

Using redirect "helpdesk@localhost" also produces same result as above.

At a loss here and would appreciate any suggestions.

Last edited by ichpen; 2nd January 2012 at 17:32.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3: can't send or receive messages zogthegreat Installation/Configuration 6 22nd May 2010 14:45
cannot recieve email hestin Installation/Configuration 1 30th November 2009 14:05
Email piping for osTicket GOPalmer General 1 29th July 2009 20:18
email receiving died ??? + report a bug in ispconfig email add/remove coolen Installation/Configuration 14 4th November 2008 19:34
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46


All times are GMT +2. The time now is 03:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.