Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 27th December 2011, 21:10
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default outputs...

Ubuntu 10.04 32bit.


netstat -tap
--------------

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 2039/couriertcpd
tcp 0 0 *op3s *:* LISTEN 3086/couriertcpd
tcp 0 0 localhost.localdo:10024 *:* LISTEN 1490/amavisd (maste
tcp 0 0 localhost.localdo:10025 *:* LISTEN 3169/master
tcp 0 0 *:mysql *:* LISTEN 1275/mysqld
tcp 0 0 *op3 *:* LISTEN 2045/couriertcpd
tcp 0 0 *:imap2 *:* LISTEN 2027/couriertcpd
tcp 0 0 localhost.localdo:spamd *:* LISTEN 1494/spamd.pid
tcp 0 0 *:http-alt *:* LISTEN 9454/apache2
tcp 0 0 *:www *:* LISTEN 9454/apache2
tcp 0 0 *:tproxy *:* LISTEN 9454/apache2
tcp 0 0 *:ftp *:* LISTEN 3186/pure-ftpd (SER
tcp 0 0 25612-21212.vps.:domain *:* LISTEN 1301/named
tcp 0 0 localhost.locald:domain *:* LISTEN 1301/named
tcp 0 0 *:ssh *:* LISTEN 1273/sshd
tcp 0 0 *:smtp *:* LISTEN 3169/master
tcp 0 0 localhost.localdoma:953 *:* LISTEN 1301/named
tcp 0 0 *:https *:* LISTEN 9454/apache2
tcp 0 0 localhost.localdo:mysql localhost.localdo:46648 ESTABLISHED 1275/mysqld
tcp 0 0 localhost.localdo:43227 localhost.localdo:mysql ESTABLISHED 1495/amavisd (ch18-
tcp 0 0 localhost.localdo:46648 localhost.localdo:mysql ESTABLISHED 1498/amavisd (ch17-
tcp 0 0 localhost.localdo:mysql localhost.localdo:43227 ESTABLISHED 1275/mysqld
tcp 0 0 25612-21212.vps.d:imaps CPE-124-181-115-1:44298 ESTABLISHED 3331/couriertls
tcp 0 240 25612-21212.vps.dig:ssh CPE-124-181-115-1:34614 ESTABLISHED 7298/sshd: root@tty
tcp 0 0 25612-21212.vps.d:imaps CPE-124-181-115-1:46038 ESTABLISHED 26486/couriertls
--------------------------

iptables -L

--------------------------

Chain INPUT (policy DROP)
target prot opt source destination
fail2ban-ssh tcp -- anywhere anywhere multiport dports ssh
DROP tcp -- anywhere 127.0.0.0/8
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT all -- anywhere anywhere
DROP all -- base-address.mcast.net/4 anywhere
PUB_IN all -- anywhere anywhere
PUB_IN all -- anywhere anywhere
PUB_IN all -- anywhere anywhere
PUB_IN all -- anywhere anywhere
DROP all -- anywhere anywhere

Chain FORWARD (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
DROP all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
PUB_OUT all -- anywhere anywhere
PUB_OUT all -- anywhere anywhere
PUB_OUT all -- anywhere anywhere
PUB_OUT all -- anywhere anywhere

Chain INT_IN (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
DROP all -- anywhere anywhere


Chain INT_OUT (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere

Chain PAROLE (16 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere

Chain PUB_IN (4 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere icmp destination-unreachable
ACCEPT icmp -- anywhere anywhere icmp echo-reply
ACCEPT icmp -- anywhere anywhere icmp time-exceeded
ACCEPT icmp -- anywhere anywhere icmp echo-request
PAROLE tcp -- anywhere anywhere tcp dpt:ftp-data
PAROLE tcp -- anywhere anywhere tcp dpt:ftp
PAROLE tcp -- anywhere anywhere tcp dpt:ssh
PAROLE tcp -- anywhere anywhere tcp dpt:smtp
PAROLE tcp -- anywhere anywhere tcp dpt:domain
PAROLE tcp -- anywhere anywhere tcp dpt:www
PAROLE tcp -- anywhere anywhere tcp dptop3
PAROLE tcp -- anywhere anywhere tcp dpt:imap2
PAROLE tcp -- anywhere anywhere tcp dpt:https
PAROLE tcp -- anywhere anywhere tcp dpt:ssmtp
PAROLE tcp -- anywhere anywhere tcp dpt:imaps
PAROLE tcp -- anywhere anywhere tcp dptop3s
PAROLE tcp -- anywhere anywhere tcp dpt:mysql
PAROLE tcp -- anywhere anywhere tcp dpt:http-alt
PAROLE tcp -- anywhere anywhere tcp dpt:tproxy
PAROLE tcp -- anywhere anywhere tcp dpt:webmin
ACCEPT udp -- anywhere anywhere udp dpt:domain
ACCEPT udp -- anywhere anywhere udp dpt:mysql
DROP icmp -- anywhere anywhere
DROP all -- anywhere anywhere

Chain PUB_OUT (4 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere

Chain fail2ban-ssh (1 references)
target prot opt source destination
RETURN all -- anywhere anywhere
Reply With Quote
Sponsored Links
  #12  
Old 29th December 2011, 13:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Looks ok...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 30th December 2011, 10:47
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default it's sort of working now... don't know why...

hi Falko,

In the mean time I've removed squirrelmail and installed roundcube... which as far as I understand is just the webmail and shouldn't change the mail configuration...

the original user's email m.xander@urbancampsite.com is sending and recieving in evolution... I tried to add an additional email 'admin@urbancampsite.com' in ISPConfig and it is not recieving email... from evolution, but I've got a wordpress site on the server with admin@urbancampsite.com as contact email and it did receive email from the wordpress contact form to admin@urbancampsite.com in evolution..???

As with squirrelmail, roundcube accepts none of the login credentials of email addresses created in ISPConfig...?
Reply With Quote
  #14  
Old 30th December 2011, 19:07
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

There are a couple of messages worth noting in your logs:

Code:
Nov 30 08:52:38 25612-21212 postfix/master[27998]: fatal: bind 0.0.0.0 port 25: Address already in use
It looks from the subsequent entries in your logs that Postfix eventually started, but at some point in the past, another service was bound to port 25. Did you install fetchmail and/or exim or something?

What's the output of the following command?

Code:
netstat --listening
And how about

Code:
lsof -i TCP:25
As for these entries

Code:
postfix/smtpd[18099]: warning: 64.31.13.207: hostname 207-13-31-64.servebyte.net verification failed: Name or service not known
These are inconsequential unless that is your IP/hostname listed. Is your IP 64.31.13.207? These messages indicate that the hostname and IP address don't match. Normally, these messages are the result of bots probing the server with unusual network configurations (IP spoofing, etc.) and can be ignored.

Finally, these messages

Code:
postfix/smtpd[18118]: warning: unknown[64.31.13.207]: SASL LOGIN authentication failed: authentication failure
seem to be legitimate authentication failures... perhaps you missed a step in the tutorial and didn't install a required library somewhere along the way. We'll investigate that after you've answered my other questions.

Quote:
As with squirrelmail, roundcube accepts none of the login credentials of email addresses created in ISPConfig...?
It bears mention that for a mail user to be able to log into webmail (Roundcube or Squirrelmail), his mailbox must have IMAP support enabled. If this is already the case, then there's a problem with your IMAP authentication.

Last edited by cbj4074; 30th December 2011 at 19:13.
Reply With Quote
  #15  
Old 30th December 2011, 23:26
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default outputs...

Quote:
Originally Posted by cbj4074 View Post
There are a couple of messages worth noting in your logs:

Code:
Nov 30 08:52:38 25612-21212 postfix/master[27998]: fatal: bind 0.0.0.0 port 25: Address already in use
It looks from the subsequent entries in your logs that Postfix eventually started, but at some point in the past, another service was bound to port 25. Did you install fetchmail and/or exim or something?
--------
# apt-cache showpkg exim
Package: exim
Versions:

Reverse Depends:
exim4-config,exim
exim4-base,exim
exim4-base,exim
uucp,exim
sauce,exim 2.02-3
rmail,exim
geximon,exim
exim4-config,exim
exim4-base,exim
exim4-base,exim
Dependencies:
Provides:
Reverse Provides:
---------
# apt-cache showpkg fetchmail
Package: fetchmail
Versions:
6.3.9~rc2-4ubuntu5 (/var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages) (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_lucid_main_binary-i386_Packages
MD5: 05cb6c758ac9e6de53b36438f8f52a45


Reverse Depends:
dtc-toaster,fetchmail
echelon,fetchmail
qsf,fetchmail
fetchmailconf,fetchmail 6.3.9~rc2-4ubuntu5
dtc-toaster,fetchmail
procmail,fetchmail
Dependencies:
6.3.9~rc2-4ubuntu5 - libc6 (2 2.11) libcomerr2 (2 1.01) libgssapi-krb5-2 (2 1.7dfsg~beta1) libk5crypto3 (2 1.6.dfsg.2) libkrb5-3 (2 1.6.dfsg.2) libssl0.9.8 (2 0.9.8k-1) debianutils (2 1.7) adduser (2 3.34) lsb-base (2 3.0-6) sysv-rc (2 2.86.ds1-14.1ubuntu2) fetchmailconf (0 (null)) postfix (16 (null)) mail-transport-agent (0 (null)) resolvconf (0 (null)) ca-certificates (0 (null)) fetchmail-common (0 (null)) fetchmail-ssl (1 6.2.5-12) logcheck (3 1.1.1-9) fetchmail-common (0 (null)) fetchmail-ssl (0 (null))
Provides:
6.3.9~rc2-4ubuntu5 - fetchmail-ssl
Reverse Provides:
-----------------

- it was a fresh VPS - all they provide is a new Ubuntu 10.04 server with SSH - they use Parallels for the VM...
As for the roundcube install, I followed the Howto at http://www.howtoforge.com/how-to-ins...debian-squeeze ... and I restarted the container.

What's the output of the following command?

Code:
netstat --listening
-----------
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 *:imaps *:* LISTEN
tcp 0 0 *op3s *:* LISTEN
tcp 0 0 localhost.localdo:10024 *:* LISTEN
tcp 0 0 localhost.localdo:10025 *:* LISTEN
tcp 0 0 *:mysql *:* LISTEN
tcp 0 0 *op3 *:* LISTEN
tcp 0 0 *:imap2 *:* LISTEN
tcp 0 0 localhost.localdo:spamd *:* LISTEN
tcp 0 0 *:http-alt *:* LISTEN
tcp 0 0 *:www *:* LISTEN
tcp 0 0 *:tproxy *:* LISTEN
tcp 0 0 *:ftp *:* LISTEN
tcp 0 0 25612-21212.vps.:domain *:* LISTEN
tcp 0 0 localhost.locald:domain *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 *:smtp *:* LISTEN
tcp 0 0 localhost.localdoma:953 *:* LISTEN
tcp 0 0 *:https *:* LISTEN
udp 0 0 25612-21212.vps.:domain *:*
udp 0 0 localhost.locald:domain *:*
udp 0 0 25612-21212.vps.dig:ntp *:*
udp 0 0 localhost.localdoma:ntp *:*
udp 0 0 *:ntp *:*
Active UNIX domain sockets (only servers)
Proto RefCnt Flags Type State I-Node Path
unix 2 [ ACC ] STREAM LISTENING 528625012 @/tmp/fam-vmail-
unix 2 [ ACC ] STREAM LISTENING 499104015 /var/run/mysqld/mysqld.sock
unix 2 [ ACC ] STREAM LISTENING 499106055 /var/lib/amavis/amavisd.sock
unix 2 [ ACC ] STREAM LISTENING 499102862 @/com/ubuntu/upstart
unix 2 [ ACC ] STREAM LISTENING 499109820 /var/run/clamav/clamd.ctl
unix 2 [ ACC ] STREAM LISTENING 499110818 private/scache
unix 2 [ ACC ] STREAM LISTENING 499110823 private/maildrop
unix 2 [ ACC ] STREAM LISTENING 499110827 private/uucp
unix 2 [ ACC ] STREAM LISTENING 499110831 private/ifmail
unix 2 [ ACC ] STREAM LISTENING 499110835 private/bsmtp
unix 2 [ ACC ] STREAM LISTENING 499110839 private/scalemail-backend
unix 2 [ ACC ] STREAM LISTENING 499110843 private/mailman
unix 2 [ ACC ] STREAM LISTENING 499110849 private/amavis
unix 2 [ ACC ] STREAM LISTENING 499112931 /var/run/fail2ban/fail2ban.sock
unix 2 [ ACC ] STREAM LISTENING 499110987 /var/spool/postfix/var/run/saslauthd/mux
unix 2 [ ACC ] STREAM LISTENING 499110706 public/cleanup
unix 2 [ ACC ] STREAM LISTENING 499110219 /var/run/courier/authdaemon/socket.tmp
unix 2 [ ACC ] STREAM LISTENING 499110713 private/tlsmgr
unix 2 [ ACC ] STREAM LISTENING 499110733 private/rewrite
unix 2 [ ACC ] STREAM LISTENING 499110737 private/bounce
unix 2 [ ACC ] STREAM LISTENING 499110741 private/defer
unix 2 [ ACC ] STREAM LISTENING 499110745 private/trace
unix 2 [ ACC ] STREAM LISTENING 499110749 private/verify
unix 2 [ ACC ] STREAM LISTENING 499110753 public/flush
unix 2 [ ACC ] STREAM LISTENING 499110757 private/proxymap
unix 2 [ ACC ] STREAM LISTENING 499110761 private/proxywrite
unix 2 [ ACC ] STREAM LISTENING 499110765 private/smtp
unix 2 [ ACC ] STREAM LISTENING 499110769 private/relay
unix 2 [ ACC ] STREAM LISTENING 499110773 public/showq
unix 2 [ ACC ] STREAM LISTENING 499110777 private/error
unix 2 [ ACC ] STREAM LISTENING 499110782 private/retry
unix 2 [ ACC ] STREAM LISTENING 499110798 private/discard
unix 2 [ ACC ] STREAM LISTENING 499110802 private/local
unix 2 [ ACC ] STREAM LISTENING 499110806 private/virtual
unix 2 [ ACC ] STREAM LISTENING 499110810 private/lmtp
unix 2 [ ACC ] STREAM LISTENING 499110814 private/anvil
-------------

And how about

Code:
lsof -i TCP:25
--------------
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
master 3169 root 12u IPv4 499110696 0t0 TCP *:smtp (LISTEN)
--------------

As for these entries

Code:
postfix/smtpd[18099]: warning: 64.31.13.207: hostname 207-13-31-64.servebyte.net verification failed: Name or service not known
These are inconsequential unless that is your IP/hostname listed. Is your IP 64.31.13.207? These messages indicate that the hostname and IP address don't match. Normally, these messages are the result of bots probing the server with unusual network configurations (IP spoofing, etc.) and can be ignored.

That fine, that's not my IP...

Finally, these messages

Code:
postfix/smtpd[18118]: warning: unknown[64.31.13.207]: SASL LOGIN authentication failed: authentication failure
seem to be legitimate authentication failures... perhaps you missed a step in the tutorial and didn't install a required library somewhere along the way. We'll investigate that after you've answered my other questions.



It bears mention that for a mail user to be able to log into webmail (Roundcube or Squirrelmail), his mailbox must have IMAP support enabled. If this is already the case, then there's a problem with your IMAP authentication.
I checked the ISPConfig -email-email mailbox-'disable IMAP checkbox' unchecked...
both m.xander@urbancampsite.com & admin@urbancampsite.com evolution accounts have identical IMAP/SMTP settings but only m.xander@urbancampsite.com is receiving in evolution...
Reply With Quote
  #16  
Old 31st December 2011, 02:50
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

Just for future reference, the apt-cache command displays available packages, not installed packages. To check installed packages, use

Code:
dpkg -l "package name"
If you don't know the exact package name, use

Code:
dpkg -l | grep -i 'package name'
(no output means there are no matching packages)

That said, Postfix seems to be running, so we should probably look at authentication mechanisms next.

Which "Perfect Server" tutorial did you follow? This one? http://www.howtoforge.com/perfect-se...ot-ispconfig-3

All of these log messages are abnormal, too:

Code:
pop3d: Maximum connection limit reached for ::ffff:178.162.233.127
I assume that none of those IP addresses are yours, either, correct?

This looks like a Postfix configuration problem. Please post the contents of /etc/postfix/main.cf, and be sure to wrap it in code tags.
Reply With Quote
  #17  
Old 31st December 2011, 03:43
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default thanks for the future reference...

Quote:
Originally Posted by cbj4074 View Post
Just for future reference, the apt-cache command displays available packages, not installed packages. To check installed packages, use

Code:
dpkg -l "package name"
If you don't know the exact package name, use

Code:
dpkg -l | grep -i 'package name'
(no output means there are no matching packages)

...thanks for that...

That said, Postfix seems to be running, so we should probably look at authentication mechanisms next.

Which "Perfect Server" tutorial did you follow? This one? http://www.howtoforge.com/perfect-se...ot-ispconfig-3

No, Ubuntu 10.04 http://www.howtoforge.com/perfect-se...ispconfig-3-p3 - basically starting on pg3 as the new VPS was provided with Ubuntu 10.04 installed.


All of these log messages are abnormal, too:

Code:
pop3d: Maximum connection limit reached for ::ffff:178.162.233.127
I assume that none of those IP addresses are yours, either, correct?
Correct. 202.130.46.114 is the IP address of the server.

This looks like a Postfix configuration problem. Please post the contents of /etc/postfix/main.cf, and be sure to wrap it in code tags.
/etc/postfix/main.cf
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = 25612-21212.vps.digitalpacific.com.au
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = 25612-21212.vps.digitalpacific.com.au, localhost, localhost.localdomain

relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 52428800
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."

virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
smtpd_client_message_rate_limit = 100
owner_request_special = no
message_size_limit = 2097152
Reply With Quote
  #18  
Old 2nd January 2012, 15:39
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

While not required, I would add the following after your existing TLS-related directives:

Code:
smtpd_tls_loglevel = 0
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
This is not mentioned in the tutorial, but should be: remove your hostname from the mydestinations directive, so that the line reads

Code:
mydestination = localhost, localhost.localdomain
Postfix will complain if a given domain is used for both myhostname and mydestination.

Next, ensure that your Mail settings within the ISPConfig interface are correct. Navigate to System -> Server Services -> Mail and ensure that the values for these two menus are correct:

POP3/IMAP Daemon
Mailfilter Syntax (should be Maildrop based on the main.cf that you posted)

Finally, restart Postfix:

Code:
service postfix restart
Any change in the behavior?
Reply With Quote
  #19  
Old 3rd January 2012, 00:08
m.xander m.xander is offline
Member
 
Join Date: Dec 2011
Posts: 81
Thanks: 5
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by cbj4074 View Post
While not required, I would add the following after your existing TLS-related directives:

Code:
smtpd_tls_loglevel = 0
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
...added...

This is not mentioned in the tutorial, but should be: remove your hostname from the mydestinations directive, so that the line reads

Code:
mydestination = localhost, localhost.localdomain
...done...

Postfix will complain if a given domain is used for both myhostname and mydestination.

Next, ensure that your Mail settings within the ISPConfig interface are correct. Navigate to System -> Server Services -> Mail and ensure that the values for these two menus are correct:

POP3/IMAP Daemon ...Courier...
Mailfilter Syntax (should be Maildrop based on the main.cf that you posted)
...Maildrop...

Finally, restart Postfix:

Code:
service postfix restart
...done...

Any change in the behavior?
...no change...
Reply With Quote
  #20  
Old 3rd January 2012, 00:46
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
 
Default

Next up, mail client configuration settings. (I wish I had seen that screenshot sooner, but that's okay.)

Have you tried any mail client other than Evolution, or tried from any location on the Internet other than your current location?

Many ISPs block outgoing traffic on port 25, so you'll never be able to send mail using that port. (The logic, while flawed, is that less SPAM will come from compromised PCs if they block port 25.)

Try using port 587 for your SMTP connection. (This is the same port you will use even with STARTTLS enabled.)

If you are using SSL for some reason (instead of STARTTLS), try port 465.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50


All times are GMT +2. The time now is 19:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.