Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th December 2011, 17:25
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default spamassassin related question

following the perfect server for debian (with ISPCFG3) is spamassassin activated automatically?

I just had a look at /etc/spamassassin/local.cf and the following lines were commented:

# rewrite_header Subject *****SPAM*****
# required_score 5.0
# use_bayes 1

so now I was wondering whether I need to manually uncomment these lines or if an ISPCFG3 install uses a different config file for spamassassin?
Reply With Quote
Sponsored Links
  #2  
Old 9th December 2011, 19:29
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 38
Thanked 90 Times in 68 Posts
Default

Yes sure. Ispconfig use amavis + libraries from spamassassin. You can ignore this issue
Reply With Quote
  #3  
Old 9th December 2011, 20:55
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

ok, so no more config files editing - everything gets done by ispcfg via the policies.

thanks for confirming
Reply With Quote
  #4  
Old 15th December 2011, 17:44
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
Default

i'm still receiving quite a lot of spam on my emails.

I have activated the spam filter for a couple of users, i'm using the permissive rule, which should only allow bad headers to pass, but i still get a lot of spam on those accounts.

In one of them, i've created a Junk folder and all spam i'm storing there, twice a day i run the command

sa-learn --dbpath /var/lib/amavis/.spamassassin --spam /mail/domain/user/.Junk/cur

It says that it learnt tokens from the messages, but i still receive the spam

I'm kinda lost here cause i didn't get what i have to do to really block the spam i'm getting
Reply With Quote
  #5  
Old 15th December 2011, 17:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,703
Thanks: 819
Thanked 5,320 Times in 4,173 Posts
Default

The permissive rule has a very high spam score, this means this rule not preconfigured for high spam filter rates. You will get much better spam filtering results with the rule 'normal'.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 15th December 2011, 17:56
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Ok i just changed it i'll see how it goes now.

Also, that command i was running i found somewhere on the internet, does it help on anything?

What is the best way to train and make my spamfilter more effective?
Reply With Quote
  #7  
Old 15th December 2011, 19:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,703
Thanks: 819
Thanked 5,320 Times in 4,173 Posts
Default

Run:

sa-update

command daily on the shell e.g. as cronjob and restart amavis afterwards. The spamfilter trains iteslf automatically based on the filtered emails. This training might not have started yet because the score of the policy you selected was too high. If you still get too many spam after a few days, you can reduce the score (tag level 2) in the normal policy to 3.501
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 15th December 2011, 19:36
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
Default

This is what i get when i run the update command:


config: warning: description exists for non-existent rule AWL

channel: lint check of update failed, channel failed


Is that correct?
Reply With Quote
  #9  
Old 19th December 2011, 20:17
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Now the messages are being marked as SPAM but still flooding the mailboxes. I have chosen the "Move spam to Junk directory" but they are not going there...

I have changed the Junk directory name to portuguese on my main.inc.php file on Roundcube, does this affect it somehow?
Reply With Quote
  #10  
Old 21st December 2011, 11:59
bruno_floyd bruno_floyd is offline
Member
 
Join Date: Aug 2010
Posts: 73
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

Any inputs about this? I'm still getting a lot of SPAM on my mailboxes.
Reply With Quote
Reply

Bookmarks

Tags
spamassassin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37
ISPconfig 2.2.21 Load Averange Very High mmiyamoto General 3 6th March 2008 13:13
Question on Clamscan and SpamAssassin AZMel Installation/Configuration 3 11th January 2007 19:56
spamassassin settings question Ovidiu Server Operation 5 18th October 2005 01:06


All times are GMT +2. The time now is 20:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.