Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th December 2011, 10:43
christospgr christospgr is offline
Junior Member
 
Join Date: Dec 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Debian 6 and ISPConfig 3 Problem with vhosts

Greetings,

Thank you for providing ISPConfig 3 it's been an amazing job.
I have followed the This guide to setup my server. My server is located at hetzner I have assigned to the server 2 IP's which work.

I have setuped the IP's at the /etc/network/interfaces. I add the Sites at the DNS module and then I add the sites at the Sites module.

My problem is that all the sites I have added are redirecting to one site and the vhosts seem that they are not working. I have checked one by one and the seem to be ok. Any suggestions?

Thank you in advance
Reply With Quote
Sponsored Links
  #2  
Old 17th December 2011, 11:31
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

Ensure that you selected the ip address and not * in the website settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th December 2011, 11:36
christospgr christospgr is offline
Junior Member
 
Join Date: Dec 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is a vhost
Code:
<Directory /var/www/panagis.me>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost 88.198.57.147:80>
      DocumentRoot /var/www/panagis.me/web
  
    ServerName panagis.me
    ServerAdmin webmaster@test.me

    ErrorLog /var/log/ispconfig/httpd/panagis.me/error.log
And this is the default from site-available
Code:
<VirtualHost 88.198.57.147:80>
	ServerAdmin webmaster@localhost

DocumentRoot /var/www
	<Directory />
I am sure that is the IP selected it refuses to work.

Last edited by christospgr; 17th December 2011 at 11:40.
Reply With Quote
  #4  
Old 17th December 2011, 16:56
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
 
Default

and you entered panagis.me in the bowser URL bar and not www.panagis.me? As you did not enable the auto subdomain www, you can only access the site with panagis.me.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
ispconfig3, vhosts

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
dist-upgrading debian on ISPConfig Server khayjake General 7 2nd May 2009 20:47
ISPConfig 3.0.1.1 / Debian Lenny FTP Problem arkkimus Installation/Configuration 4 4th April 2009 15:19
Proftpd Login Problem with Debian Etch and ISPConfig Rocky Installation/Configuration 5 28th April 2007 06:42
Problem Installing ISPConfig on a Debian System xyhfna Installation/Configuration 17 6th February 2007 14:09


All times are GMT +2. The time now is 17:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.