#1  
Old 6th December 2011, 17:59
tecnea tecnea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problem with mail permissions

I Have a ISPconfig server (wich I'd setup a few months ago with the perfect server guide with debian lenny + dovecot + bind + ISPConfig Version: 3.0.3.3) and is working great. Now I'm setting up a new server (with better hardware) with debian squeeze + dovecot + bind + ISPConfig 3.0.4. In the new one I have problems with mails. When I create a mail box, the system create the folder in /var/vmail with root as owner:group (in the other server the mailboxes are created as vmail:vamil owner:gropup) and I have to changue owner/group to make this box work. I'd found a thread (http://www.howtoforge.com/forums/showthread.php?t=52164) that says that could be the configuration under system > server config > email > dovecot; but I had dovecot selected. Any Ideas??

Thank in advance
Reply With Quote
Sponsored Links
  #2  
Old 6th December 2011, 19:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,012
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

You should update your server to the latest ISPConfig version, which is 3.0.4.1. The thread you mentioned applies to ISPConfig 3.0.3.2 only.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th December 2011, 20:48
tecnea tecnea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

It's updated, I'm setting up a new server and I'd installed the last version of ISPconfig, and I'm having this error with ISPConfig 3.0.4.1

Last edited by tecnea; 7th December 2011 at 20:51. Reason: word error (my english is not very good)
Reply With Quote
  #4  
Old 7th December 2011, 22:36
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

I'm using ISPConfig 3.0.4.1, too, and my setup is virtually identical to yours, tecnea.

However, when I create a new mailbox, the owner:group is vmail:vmail, as expected.

In ISPConfig, when you browse to System -> Server Config -> example.com -> Mail tab, what values appear for "Mailuser Name" and "Mailuser Group"? root:root or vmail:vmail?

Last edited by cbj4074; 7th December 2011 at 23:18.
Reply With Quote
  #5  
Old 8th December 2011, 20:02
tecnea tecnea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for your replys cbj4070 and till.The values in System -> Server Config -> example.com -> Mail tab are vmail:vmail for "Mailuser Name" and "Mailuser Group"
Reply With Quote
  #6  
Old 8th December 2011, 21:02
tecnea tecnea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I'd changed the values for mailuser name and mailusergoup in System -> Server Config -> example.com -> Mail tab for another user and another group and then change again for vmail:vmail and now the mal folders for mailuser are created with vmail:vamil; but my problem persists. Because when you create a mailbox (for example "someuser@mydomain.com") the system creates a folder in /var/vmail named "mydomain.com" and inside this folder creates another one for "someuser". Well my system now is creating the folder "someuser" as vmail:vmail, but creates the folder "mydomain.com" as root:root and the mail system still not work. If I change the owner:group for vmail:vmail of "mydomain.com" the mail server works

(sorry if there are some errors, my english is not the best; I speak spanish)
Reply With Quote
  #7  
Old 9th December 2011, 00:45
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Okay, so the fundamental issue here is that you changed the default values on the Mail tab and it caused problems with the permissions on /var/vmail, but you later changed the values back to what you thought were the defaults, yet the problem is not resolved.

More specifically, after changing the values back to the presumed defaults, newly-created /var/vmail/example.com directories have root:root ownership. So, it is then necessary to change the the ownernship to vmail:vmail, at which point you are able to create new mailboxes that have the correct vmail:vmail ownership, e.g., at /var/vmail/example.com/webmaster.

Is all of this correct?

If so, what values do you have for "Mailuser UID" and "Mailuser GID" on that Mail tab? 5000 for both?
Reply With Quote
  #8  
Old 9th December 2011, 18:26
tecnea tecnea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

cbj4074 the problem begans after finishing the perfect server guide (http://www.howtoforge.com/perfect-se...ot-ispconfig-3) because I realized that mailboxes doesn't work. Then, trying to fix this I changed the default values on the Mail tab. I Know the default values of setup and permissions because I can see them in my other server (remember that I said that I have one ISPconfig server working great and I'm setting up another one with better hardware to migrate my sites and mailboxes) I'm thinking about setting up the server again because I tried the perfect server guide in a couple of virtual machines and everything works and when I'd setup my first server (the one that is working perfect) everything works instantly.
The values for "Mailuser UID" and "Mailuser GID" on the Mail tab are both 5000
Reply With Quote
  #9  
Old 13th December 2011, 01:56
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Unfortunately, I'm not sufficiently familiar with the inner-workings of ISPConfig to offer additional help.

Given that we've already spent so much time troubleshooting, I would just start over. It's possible that a fundamental step was missed the first time.
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
tecnea (13th December 2011)
  #10  
Old 13th December 2011, 17:40
tecnea tecnea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Ok cbj4074.... thanks anyway. I would try to start over
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 21:01
installing squirrelmail on Debian with ispconfig3 saco721 Installation/Configuration 18 1st April 2011 18:57
ISPconfig 3 some users cannot send email to outside Rockblade Installation/Configuration 7 29th April 2010 02:40
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27


All times are GMT +2. The time now is 18:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.